0

i am working on a client site that has a long domain name (25 characters). when setting up AWS SES i am unable to update the CNAME DKIM records on the DNS provider as the maximum length allowed for the name field is 63 characters (per the DNS spec).

AWS SES generates CNAME records that have name fields with 69 characters (XXX._domainkey.DOMAIN-NAME.COM). compounded with this is the client wants a subdomain email account setup which would bring the length to 75 characters.

has anyone encountered this before? is there a workaround? to be clear i am not talking about the CNAME value (which i understand can be split up with quotes). i am speaking about the CNAME name field itself.

  • 1
    CNAME values can't be split with quotes either. You may be confusing them with TXT records. As for your main issue, I'd suggest talking to AWS support, because it's ultimately a bug in their systems. – womble Aug 21 '19 at 2:27
  • good point there. i have posted in their forum but unfortunately the plan the client has with AWS does not provide tech support. – vampiire Aug 21 '19 at 18:54
  • Time to get the client to pony up more dough, then. – womble Aug 21 '19 at 22:29
0

I just run into this issue yesterday with a lengthy domain name. After some teething hours to find a solution to it, it is due to Namecheap and Enom accepting below the recommended number of characters in their system. As far as I know, there is no workaround other than using a different service provider. If someone knows otherwise, please share.

| improve this answer | |
0

i also ran into this same issue yesterday, trying to insert AWS SES DKIM strings into enom host records, specifically the CNAME name field, and running into enom's self-imposed 60 character limit.

the solution that worked for me was to truncate the name field by removing the domain name at the end of the string. specifically, if your domain is "foo.com", AWS issues a name field like:

"[key]._domainkey.foo.com"

i replaced mine with:

"[key]._domainkey"

and my domain verified successfully. the DKIM parser doesn't seem to require (or infers) the domain name, i'm only guessing at the logic, but it worked for me. hope it works for someone else too.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.