1

I'm kinda lost, my ESXi kungfu is not strong enough obviously. What I did is put the server into maintenance and install the vib ESXi600-201905001.zip via ssh://esxcli software vib install --depot=/vmfs/volumes/...zip which worked fine and then I finished off by reboot but now I cannot see any storage anymore. vSphere-Client can also not find any drives, disk or such.

I tried some commands and recommended by the internet but none of them helped:

esxcfg-volume -l #shows nothing
esxcli storage vmfs extent list #shows nothing
esxcli storage vmfs snapshot list #shows nothing

the only command that shows something is esxcli storage filesystem list but the volumes have no names anymore

Mount Point                                        Volume Name  UUID                                 Mounted  Type       Size      Free
-------------------------------------------------  -----------  -----------------------------------  -------  ----  ---------  --------
/vmfs/volumes/53604056-a33ee2a8-e6ca-0cc47aab4cfe               53604056-a33ee2a8-e6ca-0cc47aab4cfe     true  vfat  299712512  84172800
/vmfs/volumes/8b6b7ee9-eee037bd-f068-7adeee1c369e               8b6b7ee9-eee037bd-f068-7adeee1c369e     true  vfat  261853184  62386176
/vmfs/volumes/1461ebe2-641ebb2e-0a5a-58f5a4cbba15               1461ebe2-641ebb2e-0a5a-58f5a4cbba15     true  vfat  261853184  62996480

I have no clue how to debug this or mount it, so I hope one can lead me into the right direction how to make my ESXi see my VM's again. We had 2 datastores with raid1 and raid10 but when I try to add them via vSphere the disk list is empty.

ESXI

  • shows no datastores: no datastores

  • when trying to add a device: no devices with free space

vSphere

  • also no datastores: no persistent storage

  • when trying to add a device: no disk/lun

Thanks for hints, tips and workaround in advance :)

  • 1
    What does your 'storage adapters' tab look like? What version did you go from? Oh and what's the full HW spec? – Chopper3 Aug 27 '19 at 15:12
  • from 6.0.0 Update 1 to 6.0.0 Update 3 (Build 13635687) the tab shows 11 vmhba Wellsburg AHCI Controller, 1 iSCSI Software Adapter and 1 USB Storage Controller the system is a X10DRi with 2x Xeon E5-2623 v3, 64GB RAM and an Adaptec ASR-8805 - 12G SAS. One co-worker suggested that the drivers are incompatible with the update, but since it was just a minor-update with bug fixes, I'm not sure that's a possibility – MushyPeas Aug 28 '19 at 8:42
1

So, the problem was that the AACRAID needed an update.

To find the proper bundle, you have to check VMware HCL for IO Devices: https://www.vmware.com/resources/compatibility/search.php?deviceCategory=io

I had to install the Adaptec_Inc_bootbank_scsi-aacraid_6.0.6.2.1.57013-1OEM.600.0.0.2494585 offline bundle and now my storage is back at last. Next ESXi update will be skipped :D

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.