2

I just added a NAS to our office network. The office runs on all windows 10 desktops, 22 in total. All but 2 machines see the shares fine. I could inspect one of them, and found the following:

  1. I can ping the NAS by name and by ip.
  2. NAS shows up as a discovered host in file explorer.
  3. I can not browse to the NAS using name or ip, resulting in error 53 network path not found.
  4. I cannot browse to any other share on the local network, with the same error, neither by name nor by ip, also other nodes are also discovered fine.
  5. I can browse to localhost and 127.0.0.1 just fine.
  6. Other nodes can access shares on this node.

What should I try to have this resolved?

Additional information: It turned out that the computers can access shares on Windows XP computers just fine. I found that out when we activated one of our older spares.

What I tried additional: disabled firewall disabled ipv6

Additional information: I can't browse the shares, but I get the authentication popup when trying to connect to a machine that needs it.

gpresult -r results in similar outputs for the working and not working machines.

Additional information: I checked using powershell, and both SMB1 and SMB2 is enabled on the machines.

  • If they are on the same domain it should have nothing to do with IPv6 and/ or Windows Firewall (if all clients are configured the same). Check if the GPOs are getting applied (gpresult -r), DNS in general, check the eventlogs of the machines, etc. – Lenniey Sep 11 '19 at 11:08
  • After your edit: check the used SMB versions in these clients, maybe they're using something older (e.g. v1) – Lenniey Sep 11 '19 at 12:13
  • First, please, disable SMB1 in all the organization. Second, It seems you dont have a MS Domain... It will make your life easier. You mention XP, but NAS usually work on Linux capped OS, and they offer Samba (no SMB neither XP Shares). But, please, remove SMB1 from all your organization. – Carlos Garcia Sep 16 '19 at 6:41
  • I would gladly remove SMB1, I will try it on the two problematic machines, but removing from the whole oragnization is not my decision. I also recommended creating a domain, but that is also not my decision. – g_bor Sep 16 '19 at 7:48
  • Have you tried checking the clocks on the machines to make sure they are in sync? Also are they on the same domain? I am not certain based on your comment above about wanting to create a domain if another one actually exists an you want to make a new one. Also what is the NAS and the type of authentication being used? – DrWatson128 Sep 16 '19 at 19:21
1

After some more tweaking of the settings what finally solved the problem was, that we found out, that the domain required password authentication. This was very well hidden in a garmada of error messages, so we finally enabled a user on the nas, and set up these two machines to connect as the user. This security setting was most probably flipped by some of the special software installed on only these two machines. One software was accounting related, another one was hardware related.

| improve this answer | |
0

As you are in the domain, it was caused by the following group policy setting:

Network Security: Restrict NTLM: Outgoing NTLM traffic to remote servers

Change it to Audit all.

enter image description here

| improve this answer | |
  • I will check it tomorrow and report back. Thanks. – g_bor Sep 17 '19 at 14:58
  • Did this helped ? – Udhy Sep 19 '19 at 11:11
  • I did not yet recevie the information from our field engineer. I will ask them and report back as soon as I can. – g_bor Sep 19 '19 at 11:14
  • The field engineer just returned from vacation. Unfortunately this did not help. Thanks for your patience. – g_bor Sep 26 '19 at 19:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.