1

HP EliteBooks (with Windows 10) keep turning off the WiFi when VPN connection is established, because the virtual network adapter is recognized as wired connection, causing both to fail.

This happens despite the LAN/WLAN switching being disabled in BIOS settings and Power Management for the adapter being turned off.

1

HP has an additional, non-configurable service for LAN/WLAN switching. Unfortunately, it doesn't respect the BIOS & system settings. Disabling the HP LAN/WLAN/WWAN Switching UWP Service solves the problem.

Group Policy:

Computer Configuration \
  Policies \
    Windows Settings \
      Security Settings \
        System Services \
          LanWlanWwanSwitchingServiceUWP (Startup Mode: Disabled)
  • 1
    That service may have been a (sort of half-baked) security feature for Windows 7. Microsoft added a group policy to provide similar functionality in Windows 8+ that probably works better for organizations that need to disable multi-homed systems. support.hp.com/us-en/document/c05821222 – Greg Askew Aug 30 '19 at 14:27
  • Nice to know the history! This had been puzzling me quite a while on an environment where some of the EliteBooks had this problem and some didn't, with identical BIOS configuration. – Esa Jokinen Aug 30 '19 at 14:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.