0

I recently transferred a domain helloorbital.com from GoDaddy to Route 53. However, when I used WhatsMyDNS to check my SOA and NS records, they are still pointing to the old registrar's records, how can I get my records to properly propagate please?

Separate question for knowledge, shouldn't my records on Route 53 take precedence once I migrate, why is it that it hasn't?

  • How recently? If less than the 48h TTL of the delegation, it would be expected to see mixed results depending on whether there is already cached data. – Håkan Lindqvist Aug 31 at 15:45
  • I see about half of What's My DNS's responses with your new Route 53 ones, so I'd imagine it's just the TTL counting down now. – ceejayoz Aug 31 at 16:48
  • "they are still pointing to the old registrar's records" they are pointing to old NS records maybe. DNS provider and domain name registrar are two different jobs with different consequences. Each can also be the other at the same time (all domain name registrars are typically DNS providers too, and some DNS providers like Cloudflare are now registrars), but what matters in your case is the DNS part, not the registrar part. – Patrick Mevzek Aug 31 at 20:15
  • 1
    Prior to moving name servers you should have updated the name server dns records to have a TTL of 60 seconds so the flip will happen after a 1 minute delay not a 172800 delay ( 48 hours ) ... I would do this update now to encourage a quick cutover – Scott Stensland Aug 31 at 22:53
3

The registry nameservers correctly list your new provider as authoritative on your domain:

$ dig helloorbital.com @a.gtld-servers.net NS 

; <<>> DiG 9.11.5-P1-1ubuntu2.5-Ubuntu <<>> helloorbital.com @a.gtld-servers.net NS
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 13856
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 4, ADDITIONAL: 2
;; WARNING: recursion requested but not available

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;helloorbital.com.      IN  NS

;; AUTHORITY SECTION:
helloorbital.com.   172800  IN  NS  ns-262.awsdns-32.com.
helloorbital.com.   172800  IN  NS  ns-939.awsdns-53.net.
helloorbital.com.   172800  IN  NS  ns-1216.awsdns-24.org.
helloorbital.com.   172800  IN  NS  ns-1864.awsdns-41.co.uk.

;; ADDITIONAL SECTION:
ns-262.awsdns-32.com.   172800  IN  A   205.251.193.6

;; Query time: 72 msec
;; SERVER: 192.5.6.30#53(192.5.6.30)
;; WHEN: sam. août 31 15:10:09 EST 2019
;; MSG SIZE  rcvd: 198

You now just have to wait. There is no "propagation" even if people say so continuously. If you did just query for your name before the switch you "polluted" your recursive resolver cache with the old nameserver information, for a TTL of 172800 seconds, that is 48 hours. Anyone else not having queried for your domain name will see "immediately" the new nameservers after the switch.

Three major public DNS services already have the correct updated information:

$ dig helloorbital.com @1.1.1.1 NS +short 
ns-939.awsdns-53.net.
ns-1216.awsdns-24.org.
ns-1864.awsdns-41.co.uk.
ns-262.awsdns-32.com.
$ dig helloorbital.com @8.8.8.8 NS +short 
ns-1216.awsdns-24.org.
ns-1864.awsdns-41.co.uk.
ns-262.awsdns-32.com.
ns-939.awsdns-53.net.
$ dig helloorbital.com @9.9.9.9 NS +short 
ns-1864.awsdns-41.co.uk.
ns-262.awsdns-32.com.
ns-939.awsdns-53.net.
ns-1216.awsdns-24.org.

So there is no real question there to answer, you were just not understanding how the DNS works and how changes appear worldwide.

  • I fixed it by doing the below, so when you looked at it it was probably my changes taking place. But thank you very much for the explanation and showing how you troubleshoot, I learnt a lot and appreciate it very much! – user1258600 Sep 1 at 2:53
0

The step I was missing is that my Name Server records were still pointing to the old setting, most likely due to an incorrect config when I was transferring the domain.

I fixed it by going to Registered Domains on Route 53, choosing the domain then changing the Name Server records.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.