I recently acquired a second heand Supermicro 2027GR-TRF with a Super X9DRG-HF motherboard. I can't access the network and I don't understand why. Both RJ45 ports are blinking green steadily.

Here what I tried to do:

  • Bios has been updated and restored to optimized default configuration
  • I tested the RJ45 straight through wire
  • I tested different ports on the switch that are working (Netgear prosafe)

The dmesg doesn't output anything relevant. Same with the commands lshw -class network and lspci | grep -i 'network|ethernet'.

The only good news is that I see both ports using the command dmidecode --type 8.

I don't know where to go from there, I tried to see if something in particular in the BIOS was disabled and didn't find anything relevant. I search the web for equivalent issues without success until now. If anyone would have pointers on what's wrong or other obvious tests I've missed to perform would be a great start.

I should mentioned that I have another server with same features that works fine and I didn't find discrepancies in the configuration (but, once again I may have missed something obvious).

Thanks a lot for your help and I hope my post is clear enough, Matt

1 Answer 1


A note on this motherboard's web page indicates that the onboard Intel NICs only work when the motherboard has two CPUs installed. This is one of the stranger compatibility issues I have ever heard, but there it is.

You should ensure that you are using a recent Linux distribution with the latest available kernel in that distribution.

  • Thanks so much, I missed that completely. With a second CPU, it works right away.
    – Matt
    Sep 5, 2019 at 7:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.