I can't access the server using ssh user@IP with the right password i get access denied even though the sshd config is set correctly i restarted it reloaded nothing worked. I generated an rsa key over one machine the only one that can access the server anny suggestions

closed as off-topic by womble Sep 24 at 0:01

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

  • run the client in verbose mode ssh -vvvvv user@ip – hardillb Sep 5 at 10:29
  • from the distant machine ? – Zineb BAGHDADI Sep 5 at 10:43

Check /etc/ssh/sshd_config on the server, maybe there are some Match Address rule or your user is not allowed to login from ssh. Check messages with ssh -vv user@IP for some hint. If you cannot reach the password prompt, check firewall rules.

Best regards


Problem Solved Reboot the Server and restart ssh services.

Not the answer you're looking for? Browse other questions tagged or ask your own question.