0

I've got a similar Azure/DNS question - I have the Site-to-Site VPN set up between Azure and the local network, have changed the DNS providers for the vNIC on the VMs to point to internal DNS numbers, have verified that vNIC has static IP and that it's gatewayed out to the VNet setup with the VPN connection. Machines on either side of the tunnel can ping each other all day long, no drops. But no DNS either.

I'll be happy to provide more detailed info, I'm posting a snippet of the IPCONFIG /ALL command here.

===


C:\windows\system32>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : XXX-YYYY-ZZZZZ
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : reddog.microsoft.com

Ethernet adapter Ethernet:

   Connection-specific DNS Suffix  . : reddog.microsoft.com
   Description . . . . . . . . . . . : Microsoft Hyper-V Network Adapter
   Physical Address. . . . . . . . . : 11-22-33-44-55-66
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::99c9:d2e8:e22b:99f4%4(Preferred)
   IPv4 Address. . . . . . . . . . . : 10.1.0.6(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Friday, September 6, 2019 7:12:53 PM
   Lease Expires . . . . . . . . . . : Tuesday, October 14, 2155 4:31:09 AM
   Default Gateway . . . . . . . . . : 10.1.0.1
   DHCP Server . . . . . . . . . . . : 168.xx.xxx.xx
   DHCPv6 IAID . . . . . . . . . . . : 12345124
   DHCPv6 Client DUID. . . . . . . . : 11-22-33-44-55-66-77-88-99-aa-bb-cc-dd-ee
   DNS Servers . . . . . . . . . . . : 192.168.0.xxx
                                       192.168.0.xxx
                                       192.168.20.xxx
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.reddog.microsoft.com:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : reddog.microsoft.com
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Teredo Tunneling Pseudo-Interface:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

3
  • What does "no DNS" mean exactly? – joeqwerty Sep 6 '19 at 23:50
  • As best as I can explain it - in the context in which I understand it - in the virtual NIC for the VM on Azure, on the option for DNS servers, you can select either the Azure default DNS servers or custom servers; which I did, and those are local 192.168.xxx.xxx addresses. That route for that network is the other side of the site-to-site VPN which is established and working. – Peter Barclay Sep 7 '19 at 0:00
  • Running an NSLOOKUP shows that indeed the VMs on the Azure side know what their primary DC is - and even enumerate the full name of the server including DNS context - but fail to resolve any DNS names on the local network side. The Azure VMs cannot resolve DNS names within the Azure network, either. All Azure VMs are part of the same subnet and virtual network (connected to local network through Azure VPN). All Azure VMs can use IP resolution to attach to SMB shares, and all can use DNS resolution to Internet addresses. – Peter Barclay Sep 7 '19 at 0:29
0

Ok - long story short, when I was running NSLOOKUP, I had failed to provide complete DNS context. Once I did, I realized that DNS traffic was passing properly.

I verified this with UDPing to port 53 (DNS) on an on prem server.

The long and the short of it was I didn't dig deep enough and followed the wrong leads.

Hope that this helps someone!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.