0

I have the following setup in Google cloud:

1)Firewall with two interfaces WAN pointing towards internet and LAN interface in another private network (10.1.1.0/24) 2) A ubuntu linux instance with only one network card in the private networ (10.1.1.10/24)

Both Firewall and Linux machines can ping each other

However when I check the route on Linux machine, the default route is pointing towards the IP 10.1.1.1, and when I try to change the default route to 10.1.1.10(LAN IP of firewall) I get the message

Network is unreachable

I have also created a virtual route in Google cloud, making default route as 10.1.1.10 for the source subnet 10.1.1.0/24 and added this to the linux machine as instance tag

I am missing on a simple step, apprecaite any support in this issue

3
  • Did you enable IP Forwarding in GCP for the firewall instance? cloud.google.com/vpc/docs/using-routes#canipforward – Michael - sqlbot Sep 8 '19 at 2:23
  • What priority did you make the new Google routing rule? Compare with the default routing rule? The number should be lower. Do NOT delete the default route as this will break Private Google Access. What is the 'next hop instance` setting? Also, see Michael's comment. – John Hanley Sep 16 '19 at 18:25
  • I have deleted the default route completely and created a new route with instance tag and added the gateway as firewall's IP, but then if I show ifconfig I still get the IP 10.1.1.1 in the linux instead of 10.1.1.10 (the firewall IP) – aman Oct 10 '19 at 6:55
0

As mention by Michael - sqlbot

I would also recommend checking if you had enabled IP Forwarding in GCP for the firewall instance, you can use this documentation here to verify if you did.

Also, can you please provide me with the any documentation/instructions you may have used when setting this project up. This will help me further investigate this issue.

I would also recommend reading routes overview on GCP public documentation that can help explain the error "Network is unreachable".

Hope this helps! I will be waiting for your response.

1
  • I have enabled IP forwarding in the firewall instance, then I deleted the default route towards internet gateway, then created a new route pointing towards the firewall interface as default gateway (added a instance tag to this so this can be added as a tag in the instace). Though I created a new route in the instance when I give ifconfig it still gives the ip of 10.1.1.1 instead of 10.1.1.10 – aman Oct 10 '19 at 6:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.