0

how to attach with new disk space and extend to file system with gcloud cli. vm instance ssh not responding and i tried all other ways. i have snapshot image of instance disk. please anybody tell me how to attach disk and extend file system size. we using ubuntu 18.04 on googel compute engine. ssh shell didn't give any response. and serial console show this message again and again.

Blockquote Sep 7 08:51:47 aexpress google-accounts: ERROR Exception calling the response handler. [Errno 2] No usable temporary directory found in ['/tmp', '/var/tmp', '/usr/tmp', '/'].#012Traceback (most recent call last):#012 File "/usr/lib/python3/dist-packages/google_compute_engine/metadata_watcher.py", line 200, in WatchMetadata#012 handler(response)#012 File "/usr/lib/python3/dist-packages/google_compute_engine/accounts/accounts_daemon.py", line 285, in HandleAccounts#012 self.utils.SetConfiguredUsers(desired_users.keys())#012 File "/usr/lib/python3/dist-packages/google_compute_engine/accounts/accounts_utils.py", line 318, in SetConfiguredUsers#012 mode='w', prefix=prefix, delete=True) as updated_users:#012 File "/usr/lib/python3.6/tempfile.py", line 681, in NamedTemporaryFile#012 prefix, suffix, dir, output_type = _sanitize_params(prefix, suffix, dir)#012 File "/usr/lib/python3.6/tempfile.py", line 269, in _sanitize_params#012 dir = gettempdir()#012 File "/usr/lib/python3.6/tempfile.py", line 437, in gettempdir#012 tempdir = _get_default_tempdir()#012 File "/usr/lib/python3.6/tempfile.py", line 372, in _get_default_tempdir#012 dirlist)#012FileNotFoundError: [Errno 2] No usable temporary directory found in ['/tmp', '/var/tmp', '/usr/tmp', '/']

1
1

Do you tried to follow this documentation [1] ? I also found this step-by-step walk-through doc [2] from a 3rd party website, that worth to give it a try.

If you already added more capacity to your disk, you can use this command line in gcloud

gcloud compute disks resize example-disk --size 250

In the other hand, If your image is recent, you should just try to reboot your VM instance. The fs are supposed to resize automatically.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.