0

To start out this is a duplicate question - however the question has no answer is at the top of the Google rankings. (I don't have enough status to answer it) macOS "mount_smbfs: server connection failed: Socket is not connected"

Scenario: - Vmware Fusion - Redhat 8.1 - MacOSX Mojave

I have setup a simple Samba share with a single user. I have successfully executed testparm on the linux system and can I call smbclient from the localhost of the linux machine and iterate over the shares.

All firewalls in the system have been turned off as well as as opening up the share to being 777 (this is a local dev environment)

also I have altered my config file as suggested in the following manner: (with 2 being the beginning of my host machines IP address) server edit /etc/samba/smb.conf. Under [global] edit the following:

hosts allow = 2.

I can ping the machine, in fact I have a tomcat server that is up and running which I am actively connecting to so I know that they machines can speak to each other.

Typing in the following:

# mount_smbfs //someuser@1.1.1.1/somedirectory ./mntpoint

mount_smbfs: server connection failed: Socket is not connected

0

The root of my specific problem seems somehow to be tied to DNS ()- after searching through a number of different forums I came across the following link: macrumors

In the event the link goes dormant I found the following:

I had a weird one with smb shares, before using a shortname like smb://myserver worked under SL but now I have to use smb://myserver.company.com and no nothing has changed in our DNS :)

I also found the following:

apple discussion

my understanding is Apple had to come up with some of its own implementation of SMB because they were using proprietary methods from MS developers as a result SMB can run into problems with some devices. I prefer CIFS for this reason.

so I did the following:

sudo vi /etc/hosts

added the following line

2.2.2.2 somename.com

saved my edits

Type the following command and press Enter:

dscacheutil -flushcache

After that type the second command and press Enter:

sudo killall -HUP mDNSResponder

then changed my query above to the following:

mount_smbfs //someone@somename.com/somedirectory ./mntpoint

They system asked for my password and it mounted. :)

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.