1

A login session (under Jessie) running certbot -d example.com -d www.example.com froze, and when I tried to run Let's Encrypt's certbot from another session, it said, "Another instance of Certbot is already running." I did a kill -HUP on the still-running process, and tried to run certbot with a --config-dir argument among other things, and got the same error.

How can I ask for the first attempt to be forgotten?

Is there a lockfile I can delete?

Thanks,

0

Here is a related post on the let's encrypt community site: https://community.letsencrypt.org/t/solved-another-instance-of-certbot-is-already-running/44690

To restate the possible soultion: ps -ef | grep certb to find the PID, then kill it.

If it is not running, try to find .certbot.lock files, and delete them.

  • I had already done a kill -HUP as mentioned in the question. – Christos Hayward Sep 11 at 12:39
  • Sending SIGHUP is often not enough. Kill means at least SIGTERM. – Daniel B 2 days ago

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.