0

I am getting a Windows Server Backup error which reads...

"A specified logon session does not exist. It may already have been terminated" Whenever I try to save a backup schedule.

In trying to diagnose this problem I've located this Microsoft post which says to "disable" the "Do Not allow storage of credentials or .NET Passports..." GPO as a solution to the problem. https://support.microsoft.com/en-us/help/968264/error-message-when-you-try-to-map-to-a-network-drive-of-a-dfs-share-by

I want to leave this GPO the way it is because cached passwords are a security liability that I cannot accept.

Is there an actual way to make Windows Server Backup function in a secure manner with this GPO setting enabled? I usually work around the problem in Task Scheduler by setting the task to run as SYSTEM, but this doesn't seem to work with Windows Server Backup.

1

User Powershell to run Windows Server Backup under SYSTEM context?

  • Interesting! So I setup a backup schedule, make a PS script to run "Wbadmin start backup", set that to run with task scheduler as SYSTEM, and then disable Windows Server Backup from running automatically? – Justin Grimes Sep 12 at 14:02
  • That's the idea although I must admit, I didn't try this combination myself. But there's usually no reason why it shouldn't work, I've never seen scheduled tasks fail under recent Windows OSes run under SYSTEM as long as you don't leave the machine with your task. – Totalcontrol Sep 12 at 14:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.