0

I have a great list of servers that I would like to tunnel through, which would be selected randomly through the "random-remote" feature, however when I try to use my config with the servers added, I get an Options error, "Maximum number of remote options (64) exceeded". I see no real reason why this has a hard limit, and so, how can one bypass it?

New contributor
ajay is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • Welcome to ServerFault! The remote-random option is described in OpenVPN's documentation as "a kind of basic load-balancing measure". Thus, 64 should be plenty. As far as why they chose 64, instead of 32 or 256, or for possible workarounds, you might try asking the OpenVPN support community -- see openvpn.net/community. – Doug Deden Sep 11 at 20:32
  • 1
    And, it's open source. So you could change the #define CONNECTION_LIST_SIZE 64 line in options.h to #define CONNECTION_LIST_SIZE 256, compile, and see if that breaks anything. – Doug Deden Sep 11 at 20:37
  • @DougDeden I am not the most confident with c++, so please bear with me if I miss something obvious here. I am looking through the repo and I find these files of interest, github.com/OpenVPN/openvpn3/blob/… github.com/OpenVPN/openvpn3/blob/master/openvpn/client/… , but I can't see options_error() being raised in relation to the size of the input. Can you see anything here? – ajay Sep 11 at 21:32
  • I also am not a C programmer, but I downloaded the source from openvpn.net/community-downloads. In src\OpenVPN\options.h, I find the definition of CONNECTION_LIST_SIZE. And in options.c, I find the code that raises the "Maximum number of …" error. – Doug Deden Sep 11 at 22:07

Your Answer

ajay is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.