We have a two-domain Active Directory forest: ourcompany.com at the root, and prod.ourcompany.com for production servers. Time is propagating properly through the root domain, but servers in the child domain are unable to sync via NTP. So the time on these servers is starting to drift, since they're relying only on the hardware clock.

WHen I type "net time" on one of the production servers, I get the following error:

Could not locate a time-server.
More help is available by typing NET HELPMSG 3912.

When I type "w32tm /resync", i get the following:

Sending resync command to local computer
The computer did not resync because no time data was available.

"w32tm /query /source" shows the following:

Free-running System Clock

We have three domain controllers in the prod.ourcompany.com subdomain (overkill, but the result of a migration - we haven't gotten rid of one of the old ones yet.) To complicate matters, the domain controllers are all virtualized, running on two different physical hosts. But the time on the domain controllers themselves is accurate - the servers that aren't DCs are the ones having problems.

Two of the DCs are running Server 2003, including the PDC emulator. The third DC is running Server 2008. (I could move the PDC emulator role to the 2008 machine if that would help.) The non-DC servers are all running Server 2008.

All other Active Directory functionality works fine in the production domain - we're only seeing problems with NTP.

I can manually sync each machine to the time source (the PDC emulator) by doing the following:

net time \\dc1.prod.ourcompany.com /set /y

But this is just a one-off, and it doesn't cause automated time syncing to start working. I guess I could create a scheduled task which runs the above command periodically, but I'm hoping there's a better way.

Does anyone have any ideas as to why this isn't working, and what we can do to fix it?

Thanks for your help,


2 Answers 2


Try this on the PDC hosting the correct time

NET TIME /SETSNTP:time.windows.com 
W32TM /config /reliable:YES
W32TM /resync /rediscover

then on each of the "client" NTP machines

W32TM /resync /rediscover
  • 1
    Isn't working anymore in Windows Server 2012 r2. NET TIME has been deprecated
    – eldblz
    Jan 4, 2016 at 13:53
  • All I had to do on one of my servers was w32tm /resync /rediscover. May 5, 2017 at 20:29
  • The /QUERYSNTP and /SETSNTP options have been deprecated. Please use w32tm.exe to configure the Windows Time Service.
    – Shayan
    Mar 15 at 14:14

Your first two steps are the make sure that nothing is screwing with your time.

  1. Use w32tm /query /configuration on the DCs that are giving you trouble, if any of outputs says "policy" instead of "local" that means that there is a Group Policy that is interfering with them. I would double-check group policy anyway. Remove them and run a "Gpupdate /force", then verify they are set to local.
  2. If you are using Hyper-V you would want to check that the "Time Synchronization" Integration Service is not enabled on the virtualized domain controllers.

Once you have verified those two things follow the procedure below to sync the PDC to the NTP pool; A much more reliable source then the windows NTP server.

W32tm /config /syncfromflags:manual /manualpeerlist:"us.pool.ntp.org"
W32tm /config /reliable:yes
W32tm /config /update
Net stop w32time && Net start w32time (Alternatively, reboot if you can)
W32tm /resync /rediscover

If it still doesn’t sync on the PDC, you may need to unregister and reregister the w32tm service.

w32tm /unregister
w32tm /register
Run commands listed above again if it’s a PDC. 

If a client or member DC doesn’t sync, first try doing a “gpupdate /force” to update the group policy.

If that still doesn't work:

Run w32tm /resync” from an elevated command prompt 

or on older systems:

net time /set  (Say “Y” when prompted)

If that STILL doesn't work run:

w32tm /config /syncfromflags:domhier /update  

Reboot the computer force a resync as seen above.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .