0

When I send mail with Thunderbird via my mail hosting provider, there's no problem. However I set up postfix in the usual way so that it functions as a send-only SMTP server on my DHCP client with no FQDN, but it fails to send.

postfix/pickup[21225]: 264F118807D3: uid=1000 rom=<my.real.acct@my.real.domain.com>
postfix/cleanup[21258]: 264F118807D3: message-id=<20190913174236.264F118807D3@localdomain>
postfix/qmgr[21226]: 264F118807D3: \
    from=<my.real.acct@my.real.domain.com>, size=366, nrcpt=1 (queue active)
postfix/smtp[21261]: 264F118807D3: to=<my-test@blah.com>, \
    relay=mail.myhosting-provider.com[5.6.7.8]:25, delay=3.3, \
    delays=0.03/0.01/3.3/0.04, dsn=5.7.1, status=bounced (host \
    mail.myhosting-provider.com[5.6.7.8] said: 550 5.7.1 Service unavailable; \ 
    client [1.2.3.4] blocked using zen.spamhaus.org (in reply to RCPT TO command))                               
postfix/cleanup[21258]: 7D65918807E6: message-id=<20190913174239.7D65918807E6@ecocore.org>
postfix/bounce[21264]: 264F118807D3: sender non-delivery notification: 7D65918807E6
postfix/qmgr[21226]: 7D65918807E6: from=<>, size=2393, nrcpt=1 (queue active)
postfix/qmgr[21226]: 264F118807D3: removed
postfix/smtp[21261]: 7D65918807E6: to=<my.real.acct@my.real.domain.com>, \
    relay=mail.myhosting-provider.com[5.6.7.8]:25, delay=3.2, \
    delays=0.01/0/3.1/0.03, dsn=5.7.1, status=bounced (host \
    mail.myhosting-provider.com[5.6.7.8] said: 550 5.7.1 Service unavailable; \
    client [1.2.3.4] blocked using zen.spamhaus.org (in reply to RCPT TO command))                   

It seems something about the relaying by postfix is different to the SMTP info that Thunderbird is sending.

I assume the configuration on my mail hosting provider is just set up to block relayed SMTP, and that there's a fundamental difference betweeen that and what Thunderbird is doing.

If so, can I do this at all? Is there a way to configure postfix to use simple SMTP protocol, assuming it's not?

2
  • zrn spamhouse is blocking your mail sending try, maybe checl your ip of your client and Server against spamhouse, btw where do you host the mail server at home?
    – djdomi
    Sep 13, 2019 at 21:23
  • yes, the server's on my home office lan. so you mean the IP address from dhcpd is getting through to the mail host at my ISP and then into the email header, which is how spamhaus is picking it up??? Can I stop that happening in postfix?
    – Adam
    Sep 13, 2019 at 21:40

1 Answer 1

1

Your home/home office IP address is blacklisted for sending email at Spamhaus, as most residential IP addresses are. Any mail recipient whose server subscribes to these blackhole lists will reject your attempts to send mail.

Your options are:

  • Move your mail server out of the house.
  • Switch your Internet connection to business class service.
3
  • OK, but what is the difference between postfix and thunderbird? Surely there is an option to configure a daemon on my soho server so that I can send email via my provider without my IP address getting into the mix, in the way that thunderbird does?
    – Adam
    Sep 14, 2019 at 8:03
  • 1
    @Adam Such email blacklisting applies to SMTP on port 25, which is what mail servers use to deliver mail between themselves. It does not apply to port 587, which is what Thunderbird and other email clients use to submit mail to a mail server. Sep 14, 2019 at 18:10
  • That's the info I was after.
    – Adam
    Sep 14, 2019 at 21:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.