-2

I need advice how to install php5 on this os. There is only php7 package available, but for my system php5 is required.

closed as off-topic by ceejayoz, yoonix, yagmoth555 Sep 18 at 16:55

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions should demonstrate reasonable business information technology management practices. Questions that relate to unsupported hardware or software platforms or unmaintained environments may not be suitable for Server Fault - see the help center." – ceejayoz, yoonix, yagmoth555
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    No versions of PHP 5 are currently supported. Time to put in the work to upgrade. php.net/supported-versions.php – ceejayoz Sep 17 at 17:13
  • the web application I use only supports php 5 unfortunately – Kostya R Sep 17 at 17:45
  • 3
    "Time to put in the work to upgrade." – ceejayoz Sep 17 at 17:53
3

Ideally, you don't. PHP 5.6 reached end-of-life in December 2018.

For the time being, deb.sury.org still has builds of PHP 5.6 available. However, these builds will only be available as long as Microsoft continues to maintain the upstream repository, so you should take immediate steps to make your code run on current versions of PHP.

If the code you are running is supplied by a third party and no updates for PHP 7 compatibility are available, start looking for alternatives. PHP 7 has been available since 2015; a failure to provide updated code for 4+ years is a sign that the application is not being maintained appropriately.

Not the answer you're looking for? Browse other questions tagged or ask your own question.