1

I have a Linux NTP server with a ublox M8Q GPS module connected via GPIO (UART @ 9600bps and PPS).

What I observe is that the local GPS source — SHM(0) — gets marked as falseticker and I'd like to understand why.

clock@clock:~ $ ntpq -p
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
 uk.pool.ntp.org .POOL.          16 p    - 1024    0    0.000    0.000   0.000
*SHM(2)          .PPS.            0 l   50   64  377    0.000   -0.007   0.007
xSHM(0)          .GPS.            0 l   50   64  377    0.000  -112.12   1.233
-85.199.214.100  .GPS.            1 u  609 1024  377   14.412    1.151   0.932
-194.80.204.184  .GPS.            1 u  452 1024  377   22.394    1.048   1.570
-srv20.arnoldthe 193.11.166.36    2 u  413 1024  377   22.348    0.106   2.006
+183.ip-51-89-15 85.199.214.101   2 u  435 1024  377   11.956    0.722   0.661
-ns3145492.ip-51 194.80.204.184   2 u  188 1024  377   12.317    1.043   1.844
+85.199.214.101  .GPS.            1 u  104 1024  377   15.372    0.654   0.231
-195.195.221.100 .GPS.            1 u  948 1024  377   27.442    2.899   2.659

The relevant part of /etc/ntpd.conf is

server 127.127.28.2 prefer
fudge  127.127.28.2 refid PPS

server 127.127.28.0
fudge  127.127.28.0 refid GPS

What would be a good way to troubleshoot this?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.