0

Query shows a very outdated reftime. Also I notice "spike_detect".

# ntpq -pcrv
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
*1.1.1.1            2.2.2.2       2 u  672 1024  377    0.307  -1353.3   0.919
associd=0 status=0613 leap_none, sync_ntp, 1 event, spike_detect,
version="ntpd 4.2.8p10@1.3728-o Tue Mar 28 09:22:06 UTC 2017 (1)",
processor="x86_64", system="Linux/3.0.101-108.35-default", leap=00,
stratum=3, precision=-22, rootdelay=27.855, rootdisp=1111.732,
refid=1.1.1.1,
reftime=e12c625a.f5448322  Wed, Sep 18 2019  9:59:22.958, *********************************
clock=e12cbb2f.db3adf3a  Wed, Sep 18 2019 16:18:23.856, peer=35646,
tc=10, mintc=3, offset=-88.245182, frequency=33.476, sys_jitter=1.582982,
clk_jitter=28.790, clk_wander=2.526

The config is this:

disable monitor
tinker panic 0
server 1.1.1.1 iburst burst prefer
restrict 1.1.1.1
restrict 127.0.0.1
restrict default kod nopeer nomodify noquery notrap

It's not running in slew mode, command line is:

/usr/sbin/ntpd -p /var/run/ntp/ntpd.pid -g -u ntp:ntp -c /etc/ntp.conf

Drift file exists and seems to be updated regularly:

-rw-r--r-- 1 ntp ntp 7 Sep 18 08:40 /var/lib/ntp/drift/ntp.drift

However, the only time it really syncs is when NTPd is restarted. I believe it should be able to correct any step by just setting the clock, but it does not do it.

Why could this be? There is nothing abnormal in the logs I could find.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.