0

I am fairly new to Google Cloud Platform(GCP) and also Kubernetes.

I was trying to run Cassandra using Kubernetes Engine and GCP provides one-click support to create everything. Because I was just testing, I decided to stop all the VM to prevent unwanted billing after I successfully created the Cassandra.

Then when I tried to run it again, it doesn't work because somehow the nodes aren't created. I decided to delete everything from the Cassandra application and also the clusters. Now I tried to do the same thing and it always fails to create the nodes. I haven't even got to the Cassandra part because I need to create the clusters and the nodes first.

Click here to see the screenshot of the error

No further error details, that's all I've got.

The clusters (Compute Engine/VM) are working fine and I've tried this three times with different regions and different names. But nothing works and the nodes keep failing. It doesn't mention why it fails. I couldn't create a running cluster because the error says that the nodes failed to start. I don't have any experience in Kubernetes and clusters.

Also, I couldn't contact support because you have to pay monthly for that and I am just doing my course project for my university course. Does anyone know what happened and how to fix it? Thanks!

0

This is most likely due to your cluster not being deleted correctly. I would manually create a cluster using this command [1], You will then be able to select it from the click to deploy menu.

[1] gcloud beta container clusters create CLUSTER_NAME \ --addons=HorizontalPodAutoscaling,HttpLoadBalancing,Istio,CloudRun \ --machine-type=n1-standard-4 \ --cluster-version=latest --zone=ZONE \ --enable-stackdriver-kubernetes \ --scopes cloud-platform

  • Hello, sorry for the late reply. I've tried that and the result is still the same: "finished with error: All cluster resources were brought up, but the cluster API is reporting that: only 0 nodes out of 3 have registered; this is likely due to Nodes failing to start correctly; try re-creating the cluster or contact support if that doesn't work." I am guessing there is something wrong with my GCP account. – Risyad Oct 8 at 10:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.