0

I have a MDT setup here which worked fine until I updated the Windows image to 1903 recently and made some other changes.

Now the PXE boot on clients fails with error "0xc000000f", missing boot configuration data files in folder \Tmp\ of the remote installation share. File names are <architecture>{<some UUID>}.bcd, e.g. x64uefi{ABC-XYZ-...}.bcd.

Screenshot of the error.

When the BCD files in Tmp\ are freshly generated, PXE Boot works, but the folder is cleared periodically and then PXE boot will fail with above error.

The files are generated after e.g. replacing the boot images in the MDT configuration, or when restarting the MDT services. I also should add that I've set up a distributed environment and the remote installation folder is replicated to other servers via DFS-R. That shouldn't affect this problem though.

My question is: Where can I configure the location of the BCD files? Because Tmp\xyz.bcd is not the default location, but \Boot\BCD is as seen here. The location hast to be set somewhere dynamically, as the UIDs change everytime and the filename in the bluescreen points to the new BCD file.

Thanks in advance for any help.

0

So... somehow this seems to be solved so far, the problem is that I changed so many variables that I don't know which actually solved the problem, but it is one of the following:

  • wdsutil /uninitialize-server, the reconfigure
  • completely recreate the WDS/RemoteInstallation share
  • completely reassign/recreate permissions for the whole folder

Also did some other things that I wouldn't consider relevant for the solution to the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.