I am unable to restore/ftp a file to my AIX 5.3 server. I am logged in as root:

# id
uid=0(root) gid=0(system) groups=2(bin),3(sys),7(security),8(cron),10(audit),11(lp)

I have set the fsize option in "/etc/security/limits" to "-1(unlimited)". I have confirmed this after rebooting the system, by the "ulimit -a" command:

# ulimit -a
time(seconds)        unlimited
file(blocks)         unlimited
data(kbytes)         unlimited
stack(kbytes)        unlimited
memory(kbytes)       unlimited
coredump(blocks)     unlimited
nofiles(descriptors) 2000

I have received the following error:

ftp> dir
200 Port command successful
150 Opening data channel for directory list.
-r--r--r-- 1 ftp ftp        5251072 Dec 29 08:19 DATACAPTURE.DBF
-r--r--r-- 1 ftp ftp     3292536832 Dec 28 19:45 OLTP.DBF
-r--r--r-- 1 ftp ftp     5174730752 Dec 28 19:45 STAGING.DBF
226 Transfer OK
ftp> get STAGING.DBF
200 Port command successful
150 Opening data channel for file transfer.
STAGING.DBF: short write
No space left on device/filesize limit exceeded.
426 Connection closed; transfer aborted.
226 ABOR command successful
2148154128 bytes received in 194.1 seconds (1.081e+04 Kbytes/s)

Directory size info of restore location:

# df -g|grep data
/dev/devddata      8.00      7.74    4%       17     1% /dprdev/data

I am answering my own question. The "ulimit" options were correct. The issue was my filesystem. I initially created the logical volumes as JFS. I tried to change the "allow large files" option to "true" when mounting the logical volume in SMIT, but the system would not allow this change. I have re-created them as JFS2 and was able to create files larger than 2 gig in size on the mount points.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.