0

I have disabled the firewall on my Azure account and my PC for testing purposes, and thus there is no firewall rule blocking my connection. I am still, however, unable to connect to my Azure VM via RDP.

I can SSH into the VM, so it does allow remote connections on at least some level.

I have set the inbound rules as follows:

113 / Port_3389 / 3389 / Any / Any / Any / Allow

65500 / DenyAllInBound / Any / Any / Any / Any / Deny

The latter being a default rule that I can't edit due to being a default rule. So - RDP port 3389 is set to allow, with a higher priority, why is the DenyAllInBound rule blocking RDP connections? I have verified with IP Flow that the DenyAllInBound rule is blocking my connection.

What am I missing?

0

Are there any other firewalls in the way? What application are you using for RDP? Is RDP enabled on the Windows VM? Is there an exception in the firewall on the Windows VM for RDP?

  • I doubt there are any firewalls in between. My ISP does not provide a firewall to my knowledge, and my own firewall and the Azure firewall was switched off when I tested this. But I think you are on the right track. I have neglected to tell that the Azure VM is running Ubuntu 18. I am running Windows 10 on my local machine. Perhaps this is where the problem lies... I feel kind of silly now; I am not an OS expert. If that is the case, could you advise how I should connect? SSH works fine, but how do I then copy a file from Windows to the VM? – Kobus Myburgh Sep 22 at 23:48
  • 1
    If you are copying from Windows to Linux either use PowerShell core or WinSCP – usabletech Sep 23 at 19:30
  • Thank you! WinSCP worked. Much appreciated. That is the answer to my related question here, so please post it so I can accept it there. serverfault.com/questions/985127/… – Kobus Myburgh Sep 23 at 21:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.