I have a web application running as an http server inside the VMWare Player guest OS, and I'm trying to access the content from the host OS. The guest is running Ubuntu, and the host is running Windows XP.

The problem is, when I try to access the application from a browser in the host OS, the content takes a very long time to load (up to a minute for a single page). A browser in the guest OS can access the application with no problems.

  • I've tried using both NAT and bridged networking, but the results are the same.
  • The Windows firewall is turned off.
  • The connection itself appears fine, as ping requests from guest to host as well as host to guest complete without errors or delays.
  • Both guest and host can access the external Internet connection without a problem.
  • I'm using VMWare Player.

Any ideas?


So, those recommendations are fairly likely to work... but the answers don't explain why it works. The most likely reason for the delay is that the web server or the browser (not obvious which) is trying to reverse-lookup the IP address of the browser to see if the address is being spoofed, and timing out on the query. So if you give it an answer locally, it responds much quicker.


Late answer. I'm trying also run RoR 3.0 application in Ubuntu guest 10.10 inside Vmware host Win7. Accessing from host os to RoR application running inside guest was very slow. Tried some things like turning of TCP offload, checksum, selecting bridge connection nothing worked. Finally tried running in RoR app in Mongrel server. It worked. I don't know why, maybe something wrong in webrick server.


I don't know what kind of application it is, but maybe try to set name for your host system. I mean to edit /etc/hosts in Ubuntu - and set there ip and any name for windows xp. For example; windowsxp (set correct ip for windowsxp).

  • He really should do this on the Host - although it probably no harm to do it on both sides so each OS can find the other by name. The relevant file on a Windows system is %systemroot%\system32\drivers\etc\hosts - format is the same but the entry there will be for the Ubuntu Guest.
    – Helvick
    Dec 31 '09 at 19:53
  • It's a ruby on rails application, but I don't think that's the culprit here...
    – toluju
    Dec 31 '09 at 20:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy