0

I have a php application which I have been hosting on IIS that has suddenly stopped working and returns a server 500 error. In an attempt to troubleshoot it I have added a Failed Request Tracing Rule with a scoop on 500 errors and this was the results.

109. view trace 
Warning 
-MODULE_SET_RESPONSE_ERROR_STATUS 


ModuleName
FastCgiModule 

Notification
128 

HttpStatus
500 

HttpReason
Internal Server Error 

HttpSubStatus
0 

ErrorCode
0 

ConfigExceptionInfo


Notification
EXECUTE_REQUEST_HANDLER 

ErrorCode
The operation completed successfully.(0x0) 
 FastCgiModule 

Although the error is not crystal clear, I have read that in FastCGI I can change Standard Error Mode from "Return Error in 500 to "Ignore and Return 200" but that doesnt seem to work.

I have seen it suggested that the application pool be changed to local system and I have also set php version in php manager but nothing is solving the issue.

Grateful if anyone could assist a setting that would allow me to see exactly what's causing that error..

Regards.

0

There seemed to be alot of ways to fix this, but what worked for me was clicking "Request Restructions from "Handler Mappings" setting Maping to file or folder, Verbs to All Verb and Access to Execute.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.