0

I new to this so followed this walkthrough to set up a vsftp server on an Ubuntu 16.04 box. With this configuration I managed to log into my ftp server and upload/download files but the thing is that I have to enter the server and then enter the subfolder which has read/write access for the user logging in. I tried to change the ftp root folder by changing

local_root=/home/$USER/ftp

to

local_root=/home/$USER/ftp/files

But this gives me GnuTLS error -15: An unexpected TLS packet was received. when I reload the server setting and try to connect.

Is there something I'm missing? What would be a recommended approach to configure vsftp so that user logs directly into its read/write folder. TLS connection is required.

  • tls had ususally nothing to do with the root dir – djdomi Oct 12 at 7:03
  • 1
    Could you show the rest of your configuration? Maybe there is some TLS - Config depending on $local_root, but this is hard to say without knowing your whole config... – Sebastian Oct 17 at 8:13
1

My solution is following:

I had to add following to vsftpd.conf

allow_writeable_chroot=YES
chroot_local_user=YES 
local_root=/home/$USER/ftp/files
user_sub_token=$USER
ssl_enable=NO --optional-- to get rid of the error

  • tried this but ssl is a requirement... still get same error – natral Oct 15 at 13:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.