1

Specs/Firmware:

Server:            IBM/Lenovo x3850 X5 (model: 7143B2G)
IMM:               YUOOH5A-1.55        (01/15/2018)
UEFI:              G0E188BUS-1.88      (05/29/2018)
DSA:               DSYTC5F-9.53        (02/17/2014)
FPGA:              G0UD92B-5.02        (03/26/2014)
USB Flash Drivess: Maxell 32GB
                   PNY 8GB
                   Some noname 8GB
                   Verbatim U3 Smart 4GB

What I wished for:
I want to boot a USB Flash Drive from internal USB. I want to run Alpine Linux in the same way other people run VMWare ESXi from USB.

What I did:
I inserted the USB Flash Drive and a USB DVD drive (with the Alpine installation disk) in the server. I could boot just fine from the USB DVD and the USB Flash Drive got detected as a valid installation medium while installing Alpine and the installation completed successfully! But after a power cycle (and detaching the USB DVD) the USB Flash Drive did not boot.

How I tried to fix this:

  • I tried F12 to force a 'USB Storage' boot
  • I have tried to upgrade all firmwares to the newest releases
  • I removed all other disks from the system
  • I disabled all other boot options than 'USB Storage' from the UEFI.
  • I removed the whole M1015 SAS controller from the system.
  • I tried booting the USB Flash Drive on a laptop PC (that worked just fine!)
  • I disabled all Boot ROMs on the networking cards from the UEFI.
  • I slept for 3 hours hoping it was a bad dream.
  • I have tried all USB connectors, internal, back and front.
  • I made the installation on three other USB Flash Drives.
  • I tried to do a normal ESXi-6.7.0u3 installation - that DID work. So the server is able to boot something!

So! I am almost down to a bare bone server with no possibilities for other hardware to take precedence on the boot process or conflicting in any way.

Possible problems:

  1. EUFI not supporting booting from USB Flash Drive: No
    It is selectable from F12 and I was able to boot VMware ESXi from a Flash drive too.
  2. The USB Flash Drive is not compatible with the server: Hmm?
    I have tried four different brands of USB Flash Drives. Anybody know of a USB Flash Drive that is known to work booting a x3850 X5? Is there a limit like 2GB or something maybe?
  3. Conflicting hardware or boot ROMs: No
    I have disabled all and even removed those that can.
  4. The installation did not create a bootable USB Flash Drive or the EUFI do not understand the boot-block: Hmm?
    The USBKey is bootable from a laptop PC of the same x86 architecture. But still there is the possibility that the EUFI do not understand the boot-block format on the Flash Drive?
  5. USB connector problem: No
    I have tried to insert the Flash Drive in internal, back and front connectors.
  6. I made a mixup and installed to an incorrect disk instead of the USB Flash Drive: No
    I have removed all other disks from the system while installing and while booting and I recognised the size of the drive the installer detected.
  7. Alpine do not support UEFI booting - No
    According to https://wiki.alpinelinux.org/wiki/Create_UEFI_boot_USB all new versions of Alpine works.

I know this got quite verbose but I just do not want to waste your time with some lame oversight. I really have tried all that I can think of here. :-)
So the big question - any hints? Currently I suspect the solution is a configuration in UEFI on the server, and not the flash drives or installation process?

Best regards,
- Morten Green Hermansen

1

1 Answer 1

2

I worked on this some more and finally solved it!

I took a second review regarding the UEFI/Legacy settings and made sure ALL the places where the word 'legacy' was mentioned, was disabled!

For some strange reason Alpine is not able to boot directly as 'USB Storage'. This is true for booting Alpine both for Flash drives and USB Harddisk. Both of these could boot directly on other computers. BUT

If I set this in the UEFI configuration it works:

[Boot Manager] -> [Add Boot Option] -> [NO VOLUME LABEL PciRoot(0x0)...] -> <EFI> -> <boot> -> "bootx64.efi"

... and then it is finally able to boot. When I see this it gives meaning, and actually selecting the exact bootfile on the device is actually very clean and nice.

Sorry for my UEFI ignorance but maybe this can help other newbies! ;-)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .