0

I'm attempting to create an instance of Crowd, mirroring its Live counterpart for our Testing environment. I've cloned the container and changed some few key configuration, as described below. The problem is that while the URL loads this test version of Crowd, clicking "Set up Crowd" gives the following error:

enter image description here

The overall landing page looks oddly plain too, without nice-looking buttons and formatting, if that's any hint.

Changes done since duplicating the container:

  1. Changed the hostname to test-crowd
  2. /var/crowd-home/crowd.properties to specify test-crowd instead of crowd
  3. /opt/atlassian-crowd-2.11.1/apache-tomcat/conf/server.xml to specify test-crowd instead of crowd
  4. /var/crowd-home/crowd.cfg.xml to specify a test database instead of the live one
  5. Modified pg_hba.conf on the test DB to allow test-crowd (this solved one error that was previously shown in catalina.out)
  6. Fixed owner of /opt/atlassian-crowd-2.11.1, which was different from Live

Output of catalina.out: https://pastebin.com/GGiCrhPT atlassian-crowd.log doesn't have a single line after the server was last stopped. I have also verified that crowd/console exists with correct permissions in /opt/atlassian-crowd-2.11.1/crowd-webapp/WEB-INF/classes/com/atlassian/crowd just as it does in Live.

Does anyone have any ideas what to check and why this Crowd clone doesn't fully work? Thanks in advance!

0

In the end, even after strenuous comparison to similar resources that are served (such as the demo-webapp, located next to crowd-webapp), I couldn't find anything indicative of the problem.

I solved it by avoiding it - I just installed (simply unzipping and placing alongside) the newest version of Crowd 3.7.0 and this issue did not appear. Perhaps nobody has to deal with it unless they're running ancient versions :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.