0

Let me explain my current situation, I'm trying to host a Wordpress in a Flexible App Engine environment, the problem is that I have activated CloudBuild triggers for a CI / CD, but at the time of deploying, CloudBuild return me the following error:

Failure status: UNKNOWN: Error Response : [4] DEADLINE_EXCEEDED

I have searched for this error and all that I have found is that CloudBuild exceeded the build time but, it is configured for 1800 seconds in the cloudbuild.yaml file and running the gcloud config set app / cloud_build_timeout command but the error persists I think the problem is when CloudBuild is trying to push the image to container registry because if I try to launch a new version of App Engine locally with the gcloud app deploy command it worked correctly, previously all the deploys work correctly, the only change I made was to the base image, I was using alpine as a base image, I tried to use the official images of ubuntu or php-fpm, but neither work, I thought maybe it was a problem with the size of the image but the strangest thing is that the deploys don't have a 100% failure rate, if run again a deploy that has failed this may work, I would like to know if someone else has experienced this error in order to know how to resolve it

  • Hi, Have you tried doing your builds using the gcloud builds submit with the --timeout flag? Also use the --verbosity="debug" tag to get more information about what is failing with the deployments. If you are using gcloud app deploy please consider to use the --verbosity="debug" to make a better diagnosis of the issue – Chris32 Oct 21 '19 at 14:53
0

You’re right, the DEADLINE_EXCEEDED error is typically raised if the request did not complete in the time allocated. With this error, the server may or may not execute the operation requested.

Since Flexible Environment doesn't impose a 60 second request deadline (like the Standard Environment does), it’s important to ensure that all calls to external services specify a timeout in order to avoid requests hanging indefinitely.

As GCP documentation mentions:

Application developers can implement their own servlet filter to kill requests that take longer than 60 seconds in the flexible environment. It is important to handle clean up correctly when killing a request thread, so that the application is not left in an inconsistent state.

Another workaround would be to try breaking the request that you're making into several smaller requests.

In addition, you can take a look into app caching. Caching PHP intermediate code will significantly improve your application's response time.

| improve this answer | |
  • Hi -- Your answer is a bit irrelevant, I'm afraid. We are not talking about the 60-second limitation on GAE... We are talking about Cloud Build here. – Nick Ryan Oct 18 '19 at 15:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.