-1

Sorry, I'm a Noob. My VM's were stopped on GCP. I managed to get 1 VM up and running no problem by restarting it. I have tried to restart the other 2 VM's and they appear to be running but I've got no webpage. The external IP addresses are correct and the same at Google Domains, but still nothing.

Am I missing something in the backend of GCP? I've tried to SSH to restart Apache using this code:

sudo /opt/bitnami/ctlscript.sh restart apache

But I am getting this code back from the VM.

  Unmonitored apache
  Syntax OK
  /opt/bitnami/apache2/scripts/ctl.sh : apache not running
  Syntax OK
  (98)Address already in use: AH00073: make_sock: unable to listen for connections on address [::]:80
  (98)Address already in use: AH00073: make_sock: unable to listen for connections on address 0.0.0.0:80
  no listening sockets available, shutting down
  AH00015: Unable to open logs
  /opt/bitnami/apache2/scripts/ctl.sh : httpd could not be started
  Monitored apache

Is this an easy fix or do I need to start afresh from a snapshot in a new VM instance? Some help would be appreciated, please.

0

You have another process already listening on port 80. It could be anoher web server like nginx or a reverse proxy for example.

Try to use :

fuser -n tcp 80

to get the PID of the process listening on port 80.

  • Hi Yann, Many thanks for getting back to me. I tried that and this is the result I got: james@wordpress-1-vm:~$ fuser -n tcp 80 -bash: fuser: command not found james@wordpress-1-vm:~$ – James Sullivan Oct 19 '19 at 8:52
  • Unfortunately there is no fuser on that linux distribution. If you inspect ps auxww you should be able to figure out what process is using port 80. – Yann Bizeul Oct 19 '19 at 19:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.