2

We are running a NodeJS server on Windows using a reverse proxy and application request routing. Basically, the node server is running locally on localhost:3000, and IIS is rewriting any external request to localhost:3000. Everything works fine.

Some of our requests can take time since we use this server to Render Videos, which leads to a "Timeout" on the proxy level. In other words, the client that sends the query gets an error (after 2 minutes everytime):

502 - Web server received an invalid response while acting as a gateway or proxy server.

So basically, the proxy or IIS isn't waiting long enough for the response from localhost:3000 and is throwing an error back to the client. Here's what we tried: 1. We changed the proxy timeout setting in ARR, to 10 minutes. No success. 2. We changed the timeout in the website node in the Sites node to 10 minutes. No success.

Does anyone have an Idea what timeout setting could be changed to fix this issue?

We activated Failed Request Tracing:

Here is the result

1 Answer 1

0

The probalem was with my nodeJS server. I was using HapiJS and the default socket timeout is 2 minutes. All you have to do is set it to whatever timeout you need.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.