1

I'm having an issue where our non-www domain is currently pointing to the correct IP, but our www is pointing to a random IP address that belongs to our host. So when we visit the www domain, it does to the login screen for Hostmonster instead of our website. I want the www to redirect to the non-www.

First we pointed the A record for the www to the same IP as our non-www domain. I waited over 12 hours and it wouldn't propagate so I contacted CS and they repushed it. Still, nothing happened.

So this time around they tried to put it in as a CNAME instead. So now the www is pointed to our non-www domain as a CNAME. Apparently the representative also added a redirect code to our htaccess (but not 100% sure on this). It's been hours and it doesn't look to have propagated either.

We've been struggling with this issue for days. Our host has been not much help so far. They are just as confused as we are. First they said it might be an issue with their server migration, then they tried changing the DNS as described above to no avail.

Normally this would be an easy process, but I'm quite frustrated at this point because visitors are thinking our website doesn't work when it's only the www that doesn't work.

I also tried private browsing, cleared my browser cache, and tried multiple devices.

Any hints on what could be the issue? Thank you.

  • What's the domain name. On SU this information is typically provided - and is important so we can do digs/lookups to isolate the fault. – davidgo Oct 19 at 18:59
  • Hi! The domain is www.mizna.org / mizna.org. I haven't tried the solution the previous contributor suggested yet, but as of now I can see that adding the www as a CNAME did not work. Thanks! – Hex1189 Oct 21 at 4:51
0

To me, it looks like a problem with your DNS management provider. Try changing your nameservers from your current DNS provider to someone's else where you can manage your records by yourself (Cloudflare would be a good option as it is free) and then point your domains with www and non-www from there (make sure to enable proxy on Cloudflare as they map your current IP with their own IP).

Other than that, check your web server configuration files (sites-enabled for nginx and apache). Make sure that your domain with www is present inside these configuration files. If your web server is nginx, then you can find your domain names inside Server block with the server_name directive and if it is Apache, then you can find it inside Virtual host block with ServerName directive.

Also, if you are using some sort of caching server (like varnish) try to purge its cache. Remove any unnecessary redirections inside your .htaccess file and only keep the force non-www redirection rule (attached below) inside it and see if it works.

RewriteEngine on
RewriteCond %{HTTP_HOST} ^www.example.com [NC]
RewriteRule ^(.*)$ https://example.com/$1 [L,R=301]

Hope that helps!

0

Its not clear to me what you have done, but what is clear is that www.mizna.org (74.220.215.94) and mizna.org (67.20.76.193) are pointing to different A records in the Aathorative DNS, with each IP address responding with different websites. There are no CNAME records associated with www.mizna.org according to an authorative lookup.

Thus if you DID update the A record for www.mizna.org either your domain name provider has not pushed that change into DNS or you update a zone file which is not authorative.

The authorative nameservers are ns1.hostmonster.com and ns2.hostmonster.com. If you are not using Hostmonster or a reseller/representative/reseller of hostmonster, then you are editing the wrong nameservers.

If you care, here is the output for www.mizna.org (The second last line is the one of interest, although you can trace the request back all the way) -

davidgo@my.systemname:/home/davidgo$ dig +trace www.mizna.org

; <<>> DiG 9.10.3-P4-Ubuntu <<>> +trace www.mizna.org
;; global options: +cmd
.           1059    IN  NS  j.root-servers.net.
.           1059    IN  NS  k.root-servers.net.
.           1059    IN  NS  l.root-servers.net.
.           1059    IN  NS  m.root-servers.net.
.           1059    IN  NS  a.root-servers.net.
.           1059    IN  NS  b.root-servers.net.
.           1059    IN  NS  c.root-servers.net.
.           1059    IN  NS  d.root-servers.net.
.           1059    IN  NS  e.root-servers.net.
.           1059    IN  NS  f.root-servers.net.
.           1059    IN  NS  g.root-servers.net.
.           1059    IN  NS  h.root-servers.net.
.           1059    IN  NS  i.root-servers.net.
.           1059    IN  RRSIG   NS 8 0 518400 20191102170000 20191020160000 22545 . ra6h66egBOBCEGhJBe9lBhZ0kGMlsm91q7i5kTiki8Cdz/MD6K/t06o2 eTRKkNd2VjNVijsYs06dqekrpGoxdKmqkqcaqKiwA2+PcrErEKUmAuVW y38Mcu51U013KLwweMH7tzHALZZYPgr6qfJN/70o4kYX3ZrgjHNj8Vdm 38RW6FbjC/2pvMhK5ULFVWAjd8FLGYUZJapykMGGHehyaIRakPb1yrud 29IIE/86YUEFHehx6Cy2LFYj34Jn+b7sucOgHBLQUp5hU6otVZTHAR5y ZR3UMMryl7qR+ntsXyowf1Oe9AaSEMh3xaa9cnQBO4lieOoci0xvVrEN m1a/hw==
;; Received 717 bytes from 127.0.1.1#53(127.0.1.1) in 9 ms

org.            172800  IN  NS  a0.org.afilias-nst.info.
org.            172800  IN  NS  a2.org.afilias-nst.info.
org.            172800  IN  NS  b0.org.afilias-nst.org.
org.            172800  IN  NS  b2.org.afilias-nst.org.
org.            172800  IN  NS  c0.org.afilias-nst.info.
org.            172800  IN  NS  d0.org.afilias-nst.org.
org.            86400   IN  DS  9795 7 1 364DFAB3DAF254CAB477B5675B10766DDAA24982
org.            86400   IN  DS  9795 7 2 3922B31B6F3A4EA92B19EB7B52120F031FD8E05FF0B03BAFCF9F891B FE7FF8E5
org.            86400   IN  RRSIG   DS 8 1 86400 20191102170000 20191020160000 22545 . W4dOrY7xNJg9zU43govlv14YzzkhzKaZiqzlhJbuaiyVRJvMA9qxYmVc CfxLGw/S2ZttoH8R91I2KaNVNAAXyQ9hd0lkMPxBGa5jmEaciUS8eP/y b0WenKaW8X96+eu/6W/WWu+PHyhXytdn/SG+harg90zbbNiFToBPXUXt Y3SdNJrpc2Vt061YBFqX+FNxHhGn+1ru0oz3bDMo4jlZuXV8mwyuWTHE ZRJpL5zYIoSp/iopn7ni99sOP/9cnIQaFLn7M0HzenGnB3JHxtU1LzkU xMJ0jnE4KlMQGxJUjk9X5CRuhcGOyZ9lgYzaPGkMVcNbE2f9CA+GpTKG QKAwAg==
;; Received 815 bytes from 198.97.190.53#53(h.root-servers.net) in 137 ms

mizna.org.      86400   IN  NS  ns1.hostmonster.com.
mizna.org.      86400   IN  NS  ns2.hostmonster.com.
h9p7u7tr2u91d0v0ljs9l1gidnp90u3h.org. 86400 IN NSEC3 1 1 1 D399EAAB H9PAES2EQ3K44BAR1F3TIUO0J45719RJ NS SOA RRSIG DNSKEY NSEC3PARAM
h9p7u7tr2u91d0v0ljs9l1gidnp90u3h.org. 86400 IN RRSIG NSEC3 7 2 86400 20191111051100 20191021041100 36752 org. LkSYx3gj9UmI5PDZNfjfYhX0zE9CExci1G+TAvrFZYj8n8dMPfQD8xo7 CzHd1epvxqK5bD3XcyxX0HCBWnwx07sXSFFPMZ+AUTiZX37D49g96NvH MFsVOD8iwW6oY1Q8Kqnq+vwj+xmyGUZocoUmgRNyR14uYgBy2lCac6Tj 8KE=
trkvk8eelrj16p1jdj0j7kdob9hbgncu.org. 86400 IN NSEC3 1 1 1 D399EAAB TRL3M5E03MKPBBEF038QIND8SJ1006AC A RRSIG
trkvk8eelrj16p1jdj0j7kdob9hbgncu.org. 86400 IN RRSIG NSEC3 7 2 86400 20191109152857 20191019142857 36752 org. P//z8r2oskhtATZ6QwYbTuzHmIV577LdQKKvNAjgt7x1c5R+pTxW7Mwi DRyCNJYu4KDV7Ao33wgMwqtmfICPCpsOGysCHxFTqIv2/G8wA+FbC5HX Dq88Q4SsU8xpWndWwB1wkNEp4zdPDcR6GZlWoC/AJ/JxgBQYei4nhuDB RMQ=
;; Received 586 bytes from 199.19.54.1#53(b0.org.afilias-nst.org) in 132 ms

www.mizna.org.      14400   IN  A   74.220.215.94
;; Received 58 bytes from 162.159.24.157#53(ns1.hostmonster.com) in 229 ms
  • Thanks, I am using hostmonster to edit the DNS. I just can't figure out where the phantom 74.220.215.94 is coming from. Nothing in the DNS points to that IP. All of it points to 67.20.76.193. Do you recommend using Cloudflare to manage the records to see what happens like the other contributor suggested? – Hex1189 Oct 21 at 15:25
  • I don't have a specific recommendation other then changing registrars or at least nameserver providerd (as you claim to have already spoken to host monster and if they have not fixed their problem). Cloudflare DNS could solve your issues. – davidgo Oct 21 at 17:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.