I'm using popular the ghettoVCB.sh script to backup my virtual server, but I have a problem with restoring virtual machines running Windows Server 2012 (VM with all flavor of Linux OS do not suffer this problem). After restoring VM with Windows Server 2012 - it won't boot - instead it displays something like this:

Windows failed to start. A recent hardware or software change might be the cause. To fix the problem:

1. Insert your Windows installation disc and restart your computer.
2. Choose your language settings, and then click "Next."
3. Click "Repair your computer."

If you do not have this disc, contact your system administrator or computer manufacturer for assistance.

Status: 0xc000000e

Info: The boot selection failed because a required device is inaccessible.

After many research I have found a solution for this problem (it has something to do with disk ID, which changes when cloning vmdk files). To make my restored VM bootable again I have to:

  1. Boot this VM from Windows installation disk and run command prompt.
  2. Issue commands “bootrec \fixmbr” and “bootrec \fixboot”.
  3. Run diskpart and change disk uniqueid to previous value (it is, value it has before backup was made).

This method has always worked fine for me (although there is a catch: you have to note disk id before restoring your VM), but recently I have to restore some newer VM with Windows Server 2016, and in this case (wonder whether it also applies to W2019) this method do not work anymore.

I’m not sure whether this problem is for W2016/W2019 in general or just I have some other problem with this particular VM. This time Windows Server starts booting, display Windows logo and spinning dots, and stay on this screen forever.

I would like to understand:

  1. Why cloning .vmdk files causes disk ID to change?
  2. How to prevent this?
  3. How to recover not bootable W2016 and W2019?

P.S. Backup is not corrupted – I could mount vmdk files to other running VM, check them, etc, - there are no errors on the /vmdk files.

Thank you in advance for any help.

P.S2: thanks to Daniel Ocando for correcting my spelling errors

  • "popular the ghettoVCB.sh scrip" - not best business practice as per site requirements. That would be integrating into backup software. – TomTom Oct 21 '19 at 13:03
  • 1
    Well – I know that it is "not best business practice" - this is quite another matter. Meanwhile I have to deal what I have available right now - namely ghettoVCB. – user71061 Oct 21 '19 at 14:15
  • 1
    You may have to deal with that, but this site has rules, you know. If you have a problem - maybe hire a professional? – TomTom Oct 21 '19 at 14:23

Have tried with enabled “quiescing”?

If not, try and test with this option:

  1. Install VMware tools on Windows Server VM
  2. Change VM_SNAPSHOT_QUIESCE=1 in ghettoVCB.sh or in ghettoVCB configuration file.
| improve this answer | |
  • 1
    Yes, the snapshot was created with "quiescing" option on, but VMware Snapshot provider service inside VM is disabled - I have to disable it, as otherwise snapshot creation has always failed. Disabling this service means, that "quiescing" option is effectively ignored (it doesn’t matter whether it is enabled or disabled, as snapshot is created with Microsoft VSS provider instead of VMware one, and Microsoft provider does not support this option). If I enable this option then, snapshot creation will fail, unless I disable “quiescing”, so it seems like a pat. – user71061 Oct 21 '19 at 13:03

Q: How to recover not bootable W2016 and W2019?

A: You have to manually boot Windows Server into so-called "Recovery Mode" and allow the OS to rebuild drivers stack and re-validate all the settings. Some products like f.e. StarWind V2V Converter do this automatically during V2V or simple cloning process.

| improve this answer | |
  • Unfortunately I can’t force my VM to show boot menu allowing choice of safe/recovery mode (I could not use method “reboot your system with shift key depressed” as system never boots, and Microsoft in his wisdom has removed old god “press F8 while booting” functionality). I can only boot to command prompt from installation CD trying to run dism /image:c:\ /cleanup-image /restorehealth /source:wim:s\sources\install.wim:2 but whatever I use as a /source option, I always got error “could not find source files”. – user71061 Oct 22 '19 at 10:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.