3

In Windows Server 2016:

  • I ran a NodeJS application on port 8080 and made the port available to the public internet. (by allowing inbound TCP connections over the port 8080 in the firewall)

  • GET Request to http://my.public.address:8080/hello, and the response is good.

  • If the GET request takes more than 2 minutes, there is a timeout. In other words, the client doing the GET request, fails after 2 minutes.

  • To make the GET request, we're using postman with 0 as a request timeout (it will wait as long as it needs for the response), so I'm guessing Windows is returning an empty response, or closing the connection exactly after 2 minutes. Why?

Is there a way to change the TCP connection timeout setting in Window Server 2016?

  • Are you sure this is related to Windows Server? Isn't this a NodeJS setting (e.g. server.timeout? – Lenniey Oct 28 at 11:28
  • Right, I was using HapiJS and the default socket timeout is 2 minutes. – MasterJohn Oct 29 at 4:52
2

The problem was with my nodeJS server. I was using HapiJS and the default socket timeout is 2 minutes. All you have to do is set it to whatever timeout you need.

Not the answer you're looking for? Browse other questions tagged or ask your own question.