While booting a Dell PowerEdge r720, UEFI crashes, making it mostly unbootable. This exception occurs after pressing F2 to get to "F2 System Setup" which means getting to the menu to switch back to BIOS boot mode is NOT possible. Using the F11 boot menu gives lets me get to the LifeCycle Controller or successfully boot the OS. The OS seems to work fine once launched, but cannot get to the part of the LifeCycle Controller to switch to BIOS boot only.

Screenshot of UEFI crashing pre-boot.

The system detected an exception during the UEFI pre-boot environment.

rip 78592CD3 DellFormsProcessorDxe.efi +010CD3  <-- Crash occurred here

The R720 had booted successfully several times after adding an unsupported "Dell EMC Boot Optimized Server Storage" card, aka Dell BOSS-s1. The BOSS is a much simpler version of the HighPoint SSD7103 RAID card. Two M.2 slots and a Marvel RAID controller to create a RAID1 mirror if desired. The purpose of these cards to is to boot the OS using solid state and to free up the spinning platters for virtual machines or other data. Conceptually they are very simple, but not officially supported until the R740 and other 14th generation hardware. Essentially, a SATA RAID controller with two M.2 slots on a PCI card, so nothing too complicated.

Can the Dell Boss-s1 with SATA SSD Drives be used to boot up a Dell R720?

  • What is your question? How to fix the errant HII form? – fpmurphy Nov 1 '19 at 1:23
  • Yes and how to get it to boot with the Dell Boss card? – rjt Nov 6 '19 at 5:55

The BOSS-S1 seems to be incompatible with UEFI, so change to BIOS bootup. Since the EFI crash prevents F2 BIOS access to disable particular PCI slots, physically removing the card was the only option. Had i been as familar with SOL and racadm at the time, i would have tried:

ssh root@iDracB
racadm>>racadm get BIOS.BiosBootSettings
racadm>>racadm get BIOS.UefiBootSettings 
racadm>>racadm set BIOS.BiosBootSettings.BootMode Bios

racadm over SOL to the iDrac would have been much easier than physical access, but not convinced it would have worked. Why? Currently, the machine has been booting in BIOS mode numerous times without problems. Yesterday, there was another UEFI exception upon bootup even though racadm get BIOS.BiosBootSettings.BootMode=Bios. That is for another question.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.