0

I have a project in Google Cloud that I'm trying to add an "editor" to (I will remain the sole project owner). I have added this person using their gmail address in the IAM permissions but the project does not show up in their projects list when they log into the GCP console.

I'm using the instructions here: https://cloud.google.com/iam/docs/granting-changing-revoking-access

  1. Open the IAM page in the GCP Console.
  2. Open the IAM page
  3. Click Select a project, choose a project, and click Open.
  4. Click Add.
  5. Enter an email address
  6. Select a role.
  7. Click Save.

Is there something that I'm missing here?

10
  • What kind of editor role are you grating to the user involved? – Miguel Oct 31 '19 at 11:31
  • When searching for the project, the user should make sure that they are also searching it in the right organization. – Miguel Oct 31 '19 at 11:33
  • I am adding the person as a project editor. We have no organisation or Cloud Identity defined. I couldn't find any information to indicate that either was necessary but I was wondering if that was perhaps a contributing factor? – Zac Soden Oct 31 '19 at 22:02
  • Have the user run this command gcloud auth list. Verify that the identity is correct. They run gcloud projects list. If your project does not show up, then you have added them wrong. If it does show up, then go to the Console, IAM, Resource Manager. Also, double-check what identity they are logging in to the Console. – John Hanley Nov 1 '19 at 4:56
  • The project shows up in the gcloud projects list listing, but not in Console->IAM->Resource Manager. We also get the same result in reverse if this person tried to add me as an editor in one of their projects. – Zac Soden Nov 1 '19 at 5:36
0

The solution to this problem seems to be patience. After adding a new user it seemed to take a few days before they could access the project correctly. I had noted somewhere in the documentation that there can be delays when adding new permissions but I was surprised how long it took!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.