We have the following issue. Our main hoster is equipped with Intel Xeon 6138 Gold (Supermicro), Hyper-V and one of our VMs is Centos 7 with WHM installed. We have been reported that the machine runs on low frequency 1.0GHz despite the fact that the CPU has higher supported frequencies. Obviously there is maybe missconfiguration in the Bios or the host machine itself (Hyper-V). Have somebody faced similar issues and can you give me a bit more clues and things where to look at. Thanks!


We followed the instructions at supermicro Turbo mode on Supermicro. Than we started only one virtual machine with assigned 8 vCPUs to it (Microsoft Hyper-V Server 2016). The behavior of the machine was exactly the one we want - entering in turbo frequency when putting load on it. But when we started all other virtual machines the clock speed went bellow 2GHz (1,4 - 1,8 GHz). We are observing it with taskmgr on the main host machine. We have in general ~ 10 virtial machines where each machine has different number VCPUs assigned to it. 2, 4, 8. In general we follow the rule to not assign more than 20 VCPUs on a virtual machine even we don't have now 15 per VM. Maybe we need to test the behavior with 1 vCPU for the second machine we will start after the first one?

  • 1
    How many cores did yo assign to the CentOS ? Did you set other reservations/limitations on other VMs ? – Overmind Nov 1 '19 at 7:30
  • We have assigned 15 vCPUs to the Centos... (In general we have 20 cores - 40 threads). – Pavel Nikolaev Nov 2 '19 at 5:07
  • Little update on the topic: We have corrected some settings related to the C and P states on the motherboard (Supermicro X10 series). Also changed the powerplan and now the clock speed gets in normal ranges. The main problem now is that when we start all VMs on the Hyper-V the CPU load/frequency is being spreaded across all CPU cores thus we get less clock speed. If only one virtual machine is started on the hyper-v than the speed is above 2GHz. Is there anything else except re-arranging Virtual Machines and proper planning on load ? – Pavel Nikolaev Nov 3 '19 at 14:57

Given your comment, looks like you are over-provisioning cores.

Intel Xeon 6138 Gold has 20 cores and 40 threats.

If you have multiple VMs whith 15-20 cores assigned you will have a performance problem due to other VMs processing a lot while the one in question has no resources left.

Generally, you should not have over 40 cores assigned to all VMs in total if you only have 1 of the specified CPUs and a maximum of 20 if you want to really play it safe.

You should clarify how many cores you assigned in total and make sure other VMs don't take too much CPU.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.