2

I have a Samba4 AD setup. I cannot understand why the server is visible on the net only by its IP address and not by hostname.

screenshot of network browsing

The configuration looks ok to me, the same as we have in other places where it's working as expected.

If I try accessing \\SERVER7 works fine.

[global]
    server services = s3fs, rpc, nbt, wrepl, ldap, cldap, kdc, drepl, winbindd, ntp_signd, kcc, dnsupdate
    realm = domain.lan
    ldap server require strong auth = no
    netbios name = SERVER7
    workgroup = DOMAIN
    server role = active directory domain controller
    log level = 5
    idmap_ldb:use rfc2307 = yes
    log file = /var/log/samba/log.%m
    ea support = yes
[users]
    path = /home/users/
    read only = no
[profiles]
    comment = Users profiles
    path = /home/profiles
    read only = no
    browsable = no

Could it be a reverse dns issue? This is the BIND config for the 10.0.0 zone:

$TTL    86400
@       IN      SOA     samba.domain.lan samba.domain.lan (
                        1997022705
                        28800
                        14400
                        3600000
                        86400 )
              NS      samba.server7.
              NS      samba.domain.lan.
              NS      server01.domain.com.
              NS      mailing.domain.com.
;              IN      NS      10.0.0.7
7                   PTR     samba.domain.lan.
7                   PTR     wpad.domain.com.
2                   PTR     server02.domain.com.
14                  PTR     mailing.domain.com.
7.0.0.10.in-addr.arpa.  IN      PTR     server7.

Sample nslookup and ipconfig from a client:

C:\Users\administrator.DOMAIN>nslookup server7.domain.lan
Server:  samba.domain.lan
Address:  10.0.0.7

Nome:    server7.domain.lan
Addresses:  10.0.0.7
          192.168.0.7

C:\Users\administrator.DOMAIN>nslookup 10.0.0.7
Server:  server7
Address:  10.0.0.7

Nome:    server7
Address:  10.0.0.7

C:\Users\administrator.DOMAIN>ipconfig /all

Configurazione IP di Windows

   Nome host . . . . . . . . . . . . . . : VM01W7
   Suffisso DNS primario . . . . . . . . : domain.lan
   Tipo nodo . . . . . . . . . . . . . . : Ibrido
   Routing IP abilitato. . . . . . . . . : No
   Proxy WINS abilitato . . . . . . . .  : No
   Elenco di ricerca suffissi DNS. . . . : domain.lan

Scheda Ethernet Connessione alla rete locale (LAN):

   Suffisso DNS specifico per connessione:
   Descrizione . . . . . . . . . . . . . : Connessione di rete Intel(R) PRO/1000 MT
   Indirizzo fisico. . . . . . . . . . . : 00-C1-44-71-14-CD
   DHCP abilitato. . . . . . . . . . . . : No
   Configurazione automatica abilitata   : Sì
   Indirizzo IPv4. . . . . . . . . . . . : 10.0.0.12(Preferenziale)
   Subnet mask . . . . . . . . . . . . . : 255.255.255.0
   Gateway predefinito . . . . . . . . . : 10.0.0.250
   Server DNS . . . . . . . . . . . . .  : 10.0.0.7
   Server WINS primario . . . . . . . .  : 10.0.0.7
   NetBIOS su TCP/IP . . . . . . . . . . : Attivato

Samba 4.3.11 on Ubuntu 16.04.

  • I think the problems is likely to be the PTR record. nslookup 10.0.0.7 randomly returns one of the three configured hosts (samba, server7 and wpad), maybe Windows is confused by this ambiguity...? – Maxxer Nov 4 at 22:17
  • Even after fixing PTR (removed the additional entries, now it replies with just one host) in Windows it's still visible as IP instead of hostsname – Maxxer Nov 26 at 10:34
0

It sounds as though your client is not configured to use the Samba 4 AD DC as its DNS provider.

Please ensure that the client is pointed as the AD DC for DNS and post the results of your nslookup for server7.domain.lan

  • Added ifconfig and nslookup output – Maxxer Nov 4 at 22:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.