0

I need to set a load balancer on an instance (or more instances, [compute engine]) with http and rtmp. Tried the default load balancers of Google, but they can't get both http and rtmp works :(

I've create a TCP load balancer with port 80 for HTTP and port 1883 for RTMP (because the default port for RTMP is not available on google's tcp load balancer.

HTTP is fine, RTMP can't work.

Backend server is NGINX, i've setted the correct ports!

0

Google offers several types of load balancers. You should use the TCP Load Balancer and not the HTTP Load Balancer.

2
  • Already tried, can't still get works both RTMP and HTTP (RTMP works, can't get works HTTP) :/ – tidpe Nov 6 '19 at 11:09
  • If you want help you have to be precise and include what you did and what errors you receive. "can't get works" is not useful. As I said, use a TCP load balancer. – John Hanley Nov 6 '19 at 14:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.