I have SSH access to a server on which I am trying to create a repository. I don't know if apache is set up correctly for this, but the server does have svn, and it does mod-dav-svn. Anyways, I ssh into the server:

-bash-3.00$ mkdir httpdocs/svn
-bash-3.00$ svnadmin create httpdocs/svn

I check that the repo was created successfully (it was), and then using tortoise svn, do a checkout from http://server.com/svn/.

The error returned was Repository moved permanently to 'http://server.com/svn/'; please relocate.

What could that indicate?

Note that I don't have root access to the server, and the sysadmin has gone to bed for the night. At this point, what steps need to be taken to get a repo up and running? A virtual host setting in apache? What about a .htaccess? Anything?


I'm not sure if this will still get looked at now, but: The sysadmin added this to the conf file for my vhost,

<Location /svn>
DAV svn
SVNParentPath /var/www/vhosts/domain/svn
AuthType Digest
AuthName "Subversion Repository"
AuthUserFile /etc/myauthfile
Require valid-user

the /etc/myauthfile was set up accordingly with the users for it. I made sure to set up the repository outside of my httpdocs and httpsdocs directory as to not conflict with any other namespaces -- I went to /svn in my home directory and created a repository. I tried to check it out from my computer, and--

svn: OPTIONS of 'http://domain/svn': 200 OK (http://domain)

This is confusing... Trying to access it via the browser yields a 404.
Is there something else I'm missing?

  • Did you want to access the repo over SSH, or over HTTP? Your title and body seem to disagree on the subject.
    – womble
    Jan 4, 2010 at 10:23
  • http, I just meant I only have remote access to the server via ssh Jan 5, 2010 at 9:15

2 Answers 2


Your main problem is down the the location you chose for your repository - You created the repository in your public_html folder.

The extra <Location></Location> stuff that the admin added to the apache config is correct, however it needs to point to a directory that is not already handled by Apache.

The reason you're just getting 404, and 200 responses is because Apache is intercepting your http SVN request via its regular 'website hat', rather than passing the request onto SVN.

Move the repository into a different directory that is outside of Apache's regular control, get the <location> bit updated to point to the new location of the repository.


This is a FAQ on the Subversion site. You cannot enable Subversion access over http without access to re-configure Apache:



Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.