0

I am not so into networking and I have the following problem.

I installed Kali Linux on VMWare. I am using NAT networking mode.

The default networking settings use DHCP to assign the IP address to my VM and it works fine (I can navigate). I was trying to set a fix IP so I configured it in this way:

enter image description here

Where the Gateway value should be the IP address of my router. I obtained it performing ipconfig statement into the Windows shell of my host machine:

enter image description here

Then problem is that after that I restarted my Kali VM it appears connected but I can't navigate or ping nothing.

The fixed assigned IP seems to be correct:

enter image description here

Why is it not working? What I wrong? What am I missing?

2

With an IP address of 172.16.99.225 and a netmask of 255.255.255.0 your Gateway must be in the 172.16.99.0/24 range. 192.168.1.1 does not work here.

Set it on DHCP, note the correct values and use them to configure your static IP settings.

  • Ok, as I said I am not into networking....so the problem is that with that netmask I can't see the router IP address? So I set it to DHCP, I performed an ifconfig and I discovered that the automatically assigned address is 192.168.241.128 so it means that in theory I can set a static IP like 192.168.241.1 using 255.255.255.0 netmask. Is it my reasoning correct? – AndreaNobili Nov 12 '19 at 12:21
  • 1
    That is correct. On your router you should be able to see what IP range is used for DHCP. You should choose an IP outside that range to prevent duplicate used IPs. – Gerald Schneider Nov 12 '19 at 12:23
  • 1
    if I see that correctly 192.168.241. 1 is the IP address of your host. So you should not use this IP, it is most probably the address you need to use as the gateway for your VM. – Gerald Schneider Nov 12 '19 at 12:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.