0

I would like to run hyper-v on a hyper-v server which in theory is possible. But when I try to start a VM in the child hyper-v I get an error. I checked the Event log and there it is, code 41. Hypervisor launch failed; Either VMX not present or not enabled in BIOS. We are running the host Hyper-V on an HP DL580 gen8 with 4x Xeon E7-4890 v2, 512GB Ram and 4TB accessible storage and 2x 10Gb Network.

So I've checked the BIOS and Virtualization is enabled, VT-d was enabled, I disabled it, because I read it on an old TechNet blog that U should disable it.

VT-x enabled, No-Execute Protection enabled, HT enabled, 0 Cores disabled and Power Management set to OS Controlled.

It did not made any difference that VT-d is enabled or not. The child Hyper-V always gives the same error. Oh and there is another error, if I manage the VM with Windows Admin Center when I click Virtual Machines I get an error notification that Powershell can't get CPU info, but in overview it shows the correct cpu and core count.

The child hyper-v is running in a Gen.2 VM if it makes any difference. Oh and both the Host and VM is Hyper-V Server 2019 (Core)

I read a loads of TN forum posts, blog entries about this error, but almost all suggest the same. Disable/Enable: VT, Trusted Execution, Disable Execute Bit... and turn off the machine and start up else the changes won't take effect. But this didn't helped me. How can I make this work?

2
  • "which in theory is possible." - ONLY on VERY specific INTEL chips. I am not sure an E7 v2 qualifies. Are you sure it is? – TomTom Nov 15 '19 at 13:31
  • I think it qualifies. According to MS Intel CPUs with VT-x Support. That would qualify probably all consumer i7, i9 and I think all Xeon CPUs. – Laci K Nov 15 '19 at 13:39
3

Did you try to expose the Virtualization Extensions to the VM?

Set-VMProcessor -VMName <VMName> -ExposeVirtualizationExtensions $true

Source: https://docs.microsoft.com/en-us/virtualization/hyper-v-on-windows/user-guide/nested-virtualization

1
  • I did that. But now I disabled it with Set-VMProcessor -VMName <VMName> -ExposeVirtualizationExtensions $false and re enabled it. Now it works. Probably something got messed up while I was setting up replication for the Host or when I did a windows update. I don't know. Thanks I would never thought about this if you haven't post it. – Laci K Nov 15 '19 at 13:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.