8

I am trying to install ImageMagick-devel on my CentOS 8.0.1905, but I get the following error:

# yum install ImageMagick-devel
Last metadata expiration check: 2:58:25 ago on Mon 18 Nov 2019 06:58:06 PM EST.
Error:
 Problem: conflicting requests
  - nothing provides jasper-devel needed by ImageMagick-devel-6.9.10.64-1.el8.x86_64
  - nothing provides OpenEXR-devel needed by ImageMagick-devel-6.9.10.64-1.el8.x86_64
  - nothing provides ghostscript-devel needed by ImageMagick-devel-6.9.10.64-1.el8.x86_64
  - nothing provides lcms2-devel needed by ImageMagick-devel-6.9.10.64-1.el8.x86_64

any idea how to resolve this?

1
  • Did you try to install Redmine? Than you may wait for version 4.1 which supports minimagick instead of rmagick. Described here. With this you can use GraphicsMagick. Ignore this comment if your question does not relate to Redmine/rmagick. – robsch Nov 25 '19 at 12:27
7

You need to enable the PowerTools repo. As root:

yum config-manager --set-enabled PowerTools

dnf config-manager --set-enabled PowerTools

Either of those will work as yum redirects to dnf. All of those dependencies are provided by the PowerTools repo.

3
  • Any idea why my RHEL 8 system does not have PowerTools? I have epel repo but no PowerTools... – robsch Nov 22 '19 at 11:45
  • @robsch In RHEL 8, the repo is called CodeReady Builder. You can enable it with subscription manager repos --enable codeready* if it isn't already enabled. – Nasir Riley Nov 22 '19 at 13:49
  • Unfortunately this repo is not available. I don't know why... – robsch Nov 25 '19 at 12:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.