0

I am at the ends here, I have tried every possible thing I can think of or google in order to get docker to run on boot. this is what I have tried: systemctl enable docker systemctl enable docker.service

even my wings.service for docker in /etc/systemd/system wont run either when I enable it. Every time I reboot and type service docker status it resultls in

● docker.service - Docker Application Container Engine Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled) Active: inactive (dead) Docs: https://docs.docker.com

Adding - Even newly installed programs don't start on boot by default, example glances - I tried glances run, then tried service glances status resulting in not running/active

  • 4
    Does docker start when you start it manually? Is anything in the logs? – Gerald Schneider Nov 20 '19 at 11:45
  • Is there a symlink to /lib/systemd/system/docker.service in /etc/systemd/system/multi-user.target.wants/docker.service – pfwtm Nov 20 '19 at 13:31
  • 1
    please post journalctl -u docker | tail -100̀ – Chaoxiang N Nov 21 '19 at 5:45
0

There is a ticket tracking this Ubuntu issue: https://bugs.launchpad.net/ubuntu/+source/docker/+bug/1858441

The workaround suggested in the ticket is to simply run:

systemctl enable docker  # Start Docker on next reboot
systemctl start docker  # Start Docker now
| improve this answer | |
  • OP indicated that they have run the enable docker command. – BMitch May 22 at 12:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.