0

I am not so into networking and I have the following doubt.

They provide me a Linux Ubuntu 18.04.3 LTS VM on which I have to install some tools.

The first thing that I tried was related to the Internet connectivity, so I tried to ping Google DNS:

ping 8.8.8.8

obtaining no response. so I tried to ping google.com address: same situation.

Ok...I suspected that there is no Internet connection but...I tried to perform:

wget http://google.com

and it seems to works fine: the index.html page related to google home was correctly downloaded.

So why the ping statment is not working on this VM? Where is the problem? It is a Linux configuration or something on the router?

1
  • Serverfault is for enterprise administration only, this looks more like a personal server setup you have there. Please use either one of our sister sites for questions regarding personal setups, SuperUser or Unix & Linux. – ojs Nov 23 '19 at 11:27
2

Particularly for Ubuntu, If you face problems in ubuntu running inside VM... Check If you are able to ping localhost.. If So Then surely the problem will be with NAT or Firewall.

0

This may be a case about diagnosing problems too soon.

the "first thing i tried was related to the internet connectivity". what happened then?

just because you thought "ping 8.8.8.8" would show you have internet connection has, in your example, proven wrong.

ping are, evident from your tests, different.

Read more, please.

Not the answer you're looking for? Browse other questions tagged or ask your own question.