1

For over 3 years I have routinely observed the following: while our server is busy compressing backups (7z, all cores, idle priority), the first attempt to RDP to any other computer on the local network results in a timeout. The second attempt then connects and opens immediately. Cancelling and quickly retrying the connection does not help, I have to wait out the 60 seconds.

When I record the exchange with Wireshark on both sides of the connection, I see that around 6kB of data is exchanged within the first 400ms, then the communication stalls. After 60 seconds the remote endpoint sends a RST,ACK and the RDP dialog keeps spinning for 30 more seconds before declaring a timeout. There is nothing obviously wrong in either of the captures and they don't seem to be doing any related network communication while this is happening.

What's odd is that if I do cancel and retry the connection after waiting a bit, it eventually connects. I still see the RST packet for the first connection show up on the 60-second mark. The timeout seems to be a global thing.

So... any clue what I'm dealing with here?

  • Can you clarify your first sentence? I understand you have a busy server. But what other computers are you trying to RDP to, and from where? How is the server involved in this equation? – Appleoddity Nov 25 '19 at 5:10
  • The server is my starting point, it's where I have all my management tools and where all my outgoing RDP connections originate from. The computers on the network are employee workstations, a mix of various windows versions, Vista and above. – theultramage Nov 25 '19 at 7:37
1

I've noticed similar behavior on various servers over the years... I've found that adding the following registry modification on the remote server, allows me to extend the default 60 second RDP timeout and the account will then login:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp LogonTimeout REG_DWORD Decimal: 240 (seconds)

You can easily add this new registry value using the REG.EXE command on an elevated Command Prompt (Run-as Administrator):

REG.EXE ADD "HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp" /v LogonTimeout /t REG_DWORD /d 240

(Adjust the 240 value to anything above 60. This value is in seconds.)

Please let me know if this addresses your situation!

| improve this answer | |
  • Thanks for the tip. I am hoping there is a way to eliminate that strange 60-second delay, or at least understand why it's there. I will save this as a workaround in case nothing else works. – theultramage Nov 25 '19 at 7:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.