2

I have a MDT (Microsoft Deployment Toolkit) server that I deploy OSes to our various workstations from. We use WDS (Windows Deployment Services) to handle the PXE boot part, since MDT does not have this built in. This seems to work fine for every device we have, except the Surface Laptop 3, which is new.

We have Surface Pro 4s, Surface Book 1 and 2, Surface Laptop 1 and 2 and these devices all boot fine. I'm assuming it is something different about the Surface Laptop 3, but can't find anything for the life of me.

I found some info about changing some WDS options such as standalone mode, but I don't even see that as an option in WDS. Also thinking that is not the issue since it works fine with every other device but this one.

Has anyone gotten PXE boot to work successfully with a Surface Laptop 3?

Edit: I just thought about firmware updates missing and possibly this was addressed in a BIOS update. There was one for this machine, but installing that didn't help.

4
  • 1
    What do you have DHCP option 67 - Boot File Name set to? – Joe Nov 26 '19 at 3:35
  • It's set to boot\x64\wdsnbp.com, which works on other machines except this model. Edit: Also, this comes from my Cisco switch. Option 66 is set to the server that hosts this file. – DubStep Nov 26 '19 at 15:07
  • 2
    On the WDS Server can you see if you have the following folder? c:\remoteinstall\boot\x64uefi\ ? – Joe Nov 26 '19 at 18:29
  • It's on my E: drive, but no, there is no x64uefi folder. – DubStep Nov 26 '19 at 20:27
1

I had the same issue and I was struggling with this issue, found the document. https://docs.microsoft.com/en-us/surface/ethernet-adapters-and-surface-device-deployment

It says "Booting from the network (PXE boot) is only supported when you use an Ethernet adapter or docking station from Microsoft. To boot from the network, the chipset in the Ethernet adapter or dock must be detected and configured as a boot device in the firmware of the Surface device. Microsoft Ethernet adapters, such as the Surface Ethernet Adapter and the Surface Dock use a chipset that is compatible with the Surface firmware."

Yes, I tried it with an Ethernet adapter from Microsoft and finally it worked fine. :)

1
  • I only use Microsoft Ethernet adapters, in this case, a Surface Dock, but thanks. – DubStep Jan 21 at 14:43
0

So your questions lead me down the right path. The issue is the Surface Laptop 3 apparently does not support legacy boot, which wdsnbp.com is. After doing some reading up, helper addresses is what should really be used when you need to support legacy and uefi boot modes, rather than setting option 66 and 67. Since all devices I have support UEFI boot, I simply changed the boot option in option 67 to boot\x64\wdsmgfw.efi and that worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.