0

I am currently in the process of setting up an Ubuntu server but I ran into a few problems... after setting up RAID 0 (two 160GB drives) I tried to install Ubuntu server 18.04.3 LTS but it failed while Installing GRUB

I tried "use entire disk and setup LVM" (because I wasn't sure how to set up the partitions)

I tried "use entire disk" too

The error message:

"Unable to install GRUB in /dev/mapper/Server--Name--vg--root Executing '/dev/mapper/Server--Name--vg-root' failed. This is a fatal error."

I am not sure what that means

I use BIOS ...

My motherboard is: Intel Server Board S3420GPLX

I configured RAID in BIOS...

here are some screenshots from the installation: link

they include:

  • the installer asking me to enable mdadm RAID containers

  • the installer asking me to enable ATA RAID devices

  • which disks I can select

  • error message

    (I am a newbie when it comes to Ubuntu and RAID...)

Edit:

I tried installing the Ubuntu desktop version of with LVM... and it worked ... I have absolutely no idea why it won't install the server

5
  • 1
    All virtual devices are under /dev/mapper, so you need to find the error message. Question: RAID0 on a single hard drive? – Piotr P. Karwasz Dec 5 '19 at 23:09
  • No I used two drives... – jmb05 Dec 6 '19 at 4:57
  • You'll need to install grub on both of them. Add some details on how you want to split the disk. – Piotr P. Karwasz Dec 6 '19 at 8:26
  • My disk are shown as one when I set up RAID... – jmb05 Dec 6 '19 at 20:45
  • So add all those informations to your question (you can edit it): you have BIOS or UEFI on your server, you setup your RAID in BIOS/UEFI or in the Ubuntu installer. If your RAID is configured in BIOS, what's your motherboard model (some motherboards offer software RAID, which GRUB may not understand, other hardware RAID). Did you leave some space before the first partition (BIOS) or do you have a UEFI partition. All those informations are important if you want a good answer. – Piotr P. Karwasz Dec 6 '19 at 21:45
1

I kind of fixed it because I thought I had to use the embedded RAID utility tool but I could just turn it off... maybe I will have a look at the software RAID

0

It seem you are setting the RAID in the configuration utility of the RAID controller integrated into the motherboard. If so you just need to make sure that GRUB is installed in the root of the RAID device.

For example if you see the RAID0 device as /dev/sda you should choose it as the GRUB install destination. Currently looks like you are trying to install GRUB inside the LVM which won't work.

8
  • Now the error message says: unable to install GRUB in /dev/md126p5 ... – jmb05 Dec 9 '19 at 18:25
  • You have a so called BIOS RAID as explained in this answer. Many things can get wrong, look in the logs (CTRL + ALT + 1 to reach a console, then cat /var/log/syslog). – Piotr P. Karwasz Dec 9 '19 at 20:48
  • /dev/md126p5 sounds like device md126 partition 5. In case this is so need to use the /dev/md126 device for GRUB installation. Can you please post more information about the current config of the RAID device. Maybe a screen capture of the configuration utility could help. Another screenshot of the installation wizard at the stage of choosing the installation device could also help. – Krasi Dec 10 '19 at 8:12
  • I am still wondering why installing Ubuntu desktop worked... – jmb05 Dec 10 '19 at 15:56
  • @PiotrP.Karwasz That gives me a never-ending log ... it just goes on and on – jmb05 Dec 10 '19 at 17:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.