0

This question is very like this other: Open a new cmd console on Windows 2012 Server core after closing the last one?

With one key difference that is not addressed in the other and which I have not been able to figure out through web searching. The answer very may well be that this is not possible, but I submit it to your minds to see if there is a chance that it is.

I have several installs of Windows Server without the Desktop Experience. This isn't really "Core" any longer in official Microsoft parlance, but it's what many of us appear to call it. These are running primarily Server 2016 or 2019.

My primary work setup is that I have a particularly powerful desktop computer that remains at one of my offices, and then a laptop I carry to the office I am working in, and I mostly Remote Desktop from the laptop into the desktop to do my work.

This is the where my issue diverges from the existing and good question: I am already working inside on Remote Desktop window, and then I RD into the servers when necessary, and then accidentally close the Command Prompt window.

The problem is that the first RD session captures my CTRL-SHIFT-ESC or CTRL-ALT-END and the nested session doesn't get these key presses.

Right now, the solution is to head back to the laptop's UI (out of the existing RD sessions), open a new RD into the server I'm trying to work in, use the above key combinations to open CMD prompt and reopen CMD.

But is there a way to reopen an accidentally closed CMD window within the nested RD sessions, without having to switch away from these as I have been doing?

2

Try CTRL-SHIFT-ESC instead of ALT. That directly opens Task Manager instead of going through the CTRL-ALT-DEL screen first.

Works for me on a nested core RDP session as long as both sessions are configured to send Win key combos to the remote session.

| improve this answer | |
  • Your first line indicates an error in my question which I will correct. I was using CTRL-SHIFT-ESC, not the ALT combo. Your second line identified the error: I don't use full screen for RD sessions on my Desktop, but the Windows Key Combinations setting was was to "Only when using the full screen". I have just now changed this to "On the remote computer" in the RDC settings and the pass-thru works. – music2myear Dec 6 '19 at 18:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.