1

I have 4000 awaiting emails to yahoo in my mail queue all looking like these:

(delivery temporarily suspended: lost connection with mta7.am0.yahoodns.net[98.136.96.91] while sending RCPT TO)
                                         elfo_arya@yahoo.com

D0C9B29E4F    15392 Sun Dec 15 19:31:15  nobody@arsacia.ir
(delivery temporarily suspended: lost connection with mta7.am0.yahoodns.net[98.136.96.77] while sending RCPT TO)
                                         hamid.g1380@yahoo.com

D326520AA2    15301 Sun Dec 15 10:18:40  nobody@arsacia.ir
(delivery temporarily suspended: lost connection with mta7.am0.yahoodns.net[98.136.96.91] while sending RCPT TO)
                                         Radikalsa37@yahoo.com

DD42221113    15303 Thu Dec 12 20:57:13  nobody@arsacia.ir
(delivery temporarily suspended: lost connection with mta7.am0.yahoodns.net[98.136.96.91] while sending RCPT TO)
                                         msmsad84@yahoo.com

DBED020BBA    14573 Wed Dec 11 09:05:49  nobody@arsacia.ir
(delivery temporarily suspended: lost connection with mta7.am0.yahoodns.net[98.136.96.91] while sending RCPT TO)
                                         mmd.padi81@yahoo.com

DB3A920F65    15389 Sat Dec 14 11:04:58  nobody@arsacia.ir
(delivery temporarily suspended: lost connection with mta7.am0.yahoodns.net[98.136.96.91] while sending RCPT TO)
                                         d_bidarmanesh@yahoo.com

DA9B620C72    15039 Thu Dec 12 19:07:21  nobody@arsacia.ir
(delivery temporarily suspended: lost connection with mta7.am0.yahoodns.net[98.136.96.77] while sending RCPT TO)
                                         blayk38@yahoo.com

D329020571    15542 Wed Dec 11 12:57:40  nobody@arsacia.ir
(delivery temporarily suspended: lost connection with mta7.am0.yahoodns.net[98.136.96.91] while sending RCPT TO)
                                         DanialNoise@Yahoo.Com

DC5A229CBC    15526 Sat Dec 14 15:08:39  nobody@arsacia.ir
(delivery temporarily suspended: lost connection with mta7.am0.yahoodns.net[98.136.96.91] while sending RCPT TO)
                                         omidmousavi459@yahoo.com

Affected IP: mail.arsacia.ir (89.42.211.41) (Dedicated IP address) (Not in any blacklists)

Logs in my postfix mail server when I send email to yahoo:

Dec 16 05:06:32 server postfix/submission/smtpd[3459]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
Dec 16 05:06:32 server postfix/submission/smtpd[3459]: connect from server.arsacia.ir[89.42.211.41]
Dec 16 05:06:32 server postfix/submission/smtpd[3459]: 90C4C2067B: client=server.arsacia.ir[89.42.211.41], sasl_method=LOGIN, sasl_username=root
Dec 16 05:06:32 server postfix/cleanup[3462]: 90C4C2067B: message-id=<8YSWKhJkXRVYsuRIRnO7Cz99BnsNG0VX8rI8SK08HHs@arsacia.ir>
Dec 16 05:06:32 server postfix/qmgr[3405]: 90C4C2067B: from=<noreply@arsacia.ir>, size=8530, nrcpt=1 (queue active)
Dec 16 05:06:32 server postfix/submission/smtpd[3459]: disconnect from server.arsacia.ir[89.42.211.41]
Dec 16 05:06:34 server postfix/smtp[3463]: 90C4C2067B: host mta5.am0.yahoodns.net[98.136.96.91] said: 421 4.7.0 [TSS04] Messages from 89.42.211.41 temporarily deferred due to user complaints - 4.16.55.1; see https://help.yahoo.com/kb/postmaster/SLN3434.html (in reply to MAIL FROM command)
Dec 16 05:06:34 server postfix/smtp[3463]: 90C4C2067B: lost connection with mta5.am0.yahoodns.net[98.136.96.91] while sending RCPT TO
Dec 16 05:06:37 server postfix/smtp[3463]: 90C4C2067B: to=<clubassassinha@yahoo.com>, relay=mta5.am0.yahoodns.net[67.195.228.106]:25, delay=4.7, delays=0.1/0.02/4.3/0.29, dsn=4.7.0, status=deferred (host mta5.am0.yahoodns.net[67.195.228.106] said: 421 4.7.0 [TSS04] Messages from 89.42.211.41 temporarily deferred due to user complaints - 4.16.55.1; see https://help.yahoo.com/kb/postmaster/SLN3434.html (in reply to MAIL FROM command))

This error is not in any way temporary! I'm having this for ages and it's just yahoo that I'm having problems with, this an example of log when my mail server send emails to gmail:

Dec 16 05:10:16 server postfix/submission/smtpd[3476]: connect from server.arsacia.ir[89.42.211.41]
Dec 16 05:10:16 server postfix/submission/smtpd[3476]: 4242420AAA: client=server.arsacia.ir[89.42.211.41], sasl_method=LOGIN, sasl_username=root
Dec 16 05:10:16 server postfix/cleanup[3483]: 4242420AAA: message-id=<Acf5mUPfrtqfbrXqxb5FcueIauDvAOb6YRYceqc8hVU@arsacia.ir>
Dec 16 05:10:16 server postfix/qmgr[3405]: 4242420AAA: from=<noreply@arsacia.ir>, size=8516, nrcpt=1 (queue active)
Dec 16 05:10:16 server postfix/submission/smtpd[3476]: disconnect from server.arsacia.ir[89.42.211.41]
Dec 16 05:10:18 server postfix/smtp[3484]: 4242420AAA: to=<AilSynthax@gmail.com>, relay=gmail-smtp-in.l.google.com[64.233.167.26]:25, delay=2.2, delays=0.1/0.02/1.3/0.77, dsn=2.0.0, status=sent (250 2.0.0 OK  1576473018 h189si14621274wmh.31 - gsmtp)
Dec 16 05:10:18 server postfix/qmgr[3405]: 4242420AAA: removed

This is log when I send emails to outlook:

Dec 16 05:27:11 server postfix/submission/smtpd[3524]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
Dec 16 05:27:11 server postfix/submission/smtpd[3524]: connect from server.arsacia.ir[89.42.211.41]
Dec 16 05:27:11 server postfix/submission/smtpd[3524]: 8F6C020AAA: client=server.arsacia.ir[89.42.211.41], sasl_method=LOGIN, sasl_username=root
Dec 16 05:27:11 server postfix/cleanup[3528]: 8F6C020AAA: message-id=<knpJOzRm5AS3BcRZu8ziW3UXctH9tTYqP8okB5TA@arsacia.ir>
Dec 16 05:27:11 server postfix/qmgr[3405]: 8F6C020AAA: from=<noreply@arsacia.ir>, size=8506, nrcpt=1 (queue active)
Dec 16 05:27:11 server postfix/submission/smtpd[3524]: disconnect from server.arsacia.ir[89.42.211.41]
Dec 16 05:27:16 server postfix/smtp[3529]: 8F6C020AAA: to=<AilSynthax@outlook.com>, relay=outlook-com.olc.protection.outlook.com[104.47.66.33]:25, delay=4.6, delays=0.09/0.02/2.1/2.3, dsn=2.6.0, status=sent (250 2.6.0 <knpJOzRm5AS3BcRZu8ziW3UXctH9tTYqP8okB5TA@arsacia.ir> [InternalId=12309376296217, Hostname=MW2NAM12HT052.eop-nam12.prod.protection.outlook.com] 16145 bytes in 0.327, 48.135 KB/sec Queued mail for delivery -> 250 2.1.5)
Dec 16 05:27:16 server postfix/qmgr[3405]: 8F6C020AAA: removed

And every single other email services are ok with my emails, it's just yahoo.

My postfix config:

alias_database = hash:/etc/aliases
append_dot_mydomain = no
biff = no
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
inet_interfaces = all
inet_protocols = ipv4
mailbox_size_limit = 0
milter_default_action = accept
milter_protocol = 2
mydestination = $myhostname localhost.$mydomain $mydomain
myhostname = server.arsacia.ir
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
myorigin = $mydomain
non_smtpd_milters = inet:localhost:1230
readme_directory = no
recipient_delimiter = +
relayhost =
smtp_enforce_tls = yes
smtp_tls_CAfile = /etc/ssl/certs/ca-certificates.crt
smtp_tls_security_level = may
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
smtpd_milters = inet:localhost:12301
smtpd_relay_restrictions = permit_mynetworks permit_sasl_authenticated defer_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_path = private/auth
smtpd_sasl_security_options = noanonymous, noplaintext
smtpd_sasl_tls_security_options = noanonymous
smtpd_sasl_type = dovecot
smtpd_tls_auth_only = yes
smtpd_tls_cert_file = /etc/letsencrypt/live/arsacia.ir-0003/fullchain.pem
smtpd_tls_key_file = /etc/letsencrypt/live/arsacia.ir-0003/privkey.pem
smtpd_tls_security_level = may
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes
virtual_alias_maps = hash:/etc/postfix/virtual

And here's yahoo's answer: enter image description here

They just don't give a damn about it. I'm already signed up on yahoo complaint feedback loop and received no complaints.

Also I checked mxtoolbox.com, absolutely no problems are reported and all checks are passed. I have DKIM, DMARC and SPF which are all "PASSED". Emails are encrypted using a correct SSL.

Anybody knows how to fix this problem? This is really getting annoying for me and my users who have to wait for 24hours to receive their emails from my email server.

4
  • Hi, Could someone send mass email to yahoo ? as you seem to have hit a limit, and it's related to your IP. – yagmoth555 Dec 16 '19 at 13:59
  • @yagmoth555-GoFundMeMonica No, I'm using IPS community forums and most emails are sent using that, already have captcha verification everywhere. I clear my queue and after a week, it's raising like this and then everything is burned to ashes. – rez Dec 16 '19 at 14:04
  • Yahoo is ridiculous, i.vgy.me/wLe8SX.png, I opened the issue just TODAY – rez Dec 16 '19 at 14:21
  • You will never get any suitable reply from services like Yahoo, Gmail or Outlook/Hotmail on such matters. As long as you are not a paying customer, and even then most of the time not... so you've got to figure it out on your own. – Marc Stürmer Dec 30 '19 at 19:23
2

You need to configure an outgoing rate limit on Postfix for all Yahoo domains, because obviously Yahoo dislikes your speed/level of concurrency and your MTA is always triggering some type of anti spam defense mechanism due to that.

Take a look at this blog post where the author faced the same problem, it might help:

https://www.stevejenkins.com/blog/2012/08/how-to-postfix-configuration-to-reduce-yahoo-deferrals-using-transport-maps/

A more simpler description can be found here: https://wiki.deimos.fr/Postfix:_limit_outgoing_mail_throttling.html#Limit_by_domain

If rate limiting does not work though as expected, you've got two other options: either forget about delivering emails to Yahoo completely, or use a commercial mail delivery provider for that task which has a good standing with Yahoo.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.